Support » Plugin: Better WordPress Minify » Made my site very very slow

  • I installed the plugin and I got a better css minify score, but in reality my website gets a lot slower. It’s because plugin fully loads the page, then shows it to a user and I dont want this because most of my users have low speed internet. theu should wait like 10-15 seconds and no sign of page loading. I deleted the plugin but still my website is really slow. I just want to revert everything like before.

    now, it takes 10-15 seconds for some pages to load and my landing page sometimes doesnt load. CPU and ram usage of my hosting also hits the limits.

    **Update 21/9/2014
    I deactivated all my plugins and noticed there is a conflict between BWM and rating-widget. So, my problem got solved after deleting both plugins. Again, I got a suggestion from the author of plugin to activate it and give the box of strings number of 5. now load page improved and I think it’s working well.

Viewing 12 replies - 1 through 12 (of 12 total)
  • and my page speed dropped from 67 percent to 38 %. hope some one can help me
    http://gtmetrix.com/reports/pareshstore.com/HAmNA5c9

    Plugin Author Khang Minh

    (@oddoneout)

    Hi there, I’ve just checked your site and it does load very slowly, but since BWP Minify is not active on your site it’s highly likely that it’s something else that’s causing the issue.

    Can you try deactivating all plugins and then re-activating them one by one? Try the default theme as well.

    Regarding the plugin, the first page load will be slow because it has to dynamically minify your site’s JS/CSS files, but when cache is active it should be fast.

    Thanks for answer,

    I was really worried last night,and I called my host to backup. But before that I decided to deactivate all plugins, and surprisingly everything revert to normal. Then I activate plugins one by one, and found that there is a conflict between rating-widget and BWP. I deleted rating widget and everything is fine.

    but page speed grade is still very low compared to yesterday. but I deleted the plugin.

    Plugin Author Khang Minh

    (@oddoneout)

    Maybe you can try enabling BWP Minify again? In order for the page to load faster the first time you should set the files per Minify string to something smaller for e.g. 5.

    Plugin Author Khang Minh

    (@oddoneout)

    Were you able to resolve? Would be great if you could reconsider the 1 star rating. Thank you.

    Again, I activated the plugin, but I didn’t get the good result. I mean it does the job and minify CSS but page load becomes slow. As you said I give the strig box number of 5, and now load time improved.

    what would happen if I choose 1 or 10 ? and there is a box “cache Age”, what should I put there?

    for a free plugin, you have a good support. I would reconsider my rating.

    Plugin Author Khang Minh

    (@oddoneout)

    10 is the recommended setting for most sites, but on certain servers it’s best to use a lower number, but should not be lower than 5. You can read more about this topic here: http://betterwp.net/wordpress-minify-javascript-css/

    As I said, when you first visit the site it will be slow because the plugin needs to combine and minify many JS/CSS files. Once that is done the minified contents are cached, so the second time you visit the site it will be fast because you’re seeing cached minified contents.

    “Cache age” allows you to specify the time after which the plugin needs to re-combine and minify JS/CSS files. If your JS/CSS files don’t change often you can set this to something quite high such as 7 days or 30 days, but the default setting is recommended.

    And thank you very much for reconsidering the rating.

    sahand11_m27

    (@sahand11_m27)

    thanks for infos, it’s working well now.

    But, I faced a problem. the plugin deactive bold style of my headers and bold is not working. Do you have any idea what causes it ?

    Plugin Author Khang Minh

    (@oddoneout)

    From what css file does the bold style gets applied? You can try excluding that specific css file by navigating to BWP Minify >> Manage enqueued files and choose to NOT minify it.

    sahand11_m27

    (@sahand11_m27)

    Sorry, I am beginner and I couldn’t find any tutorial to css file generating bold style. Can you tell me how I can recognize css file applying bold style?

    sahand11_m27

    (@sahand11_m27)

    Great, I found it, It’s in my theme avia Css. Now, bold style wotking.
    thank you.

    Plugin Author Khang Minh

    (@oddoneout)

    Your welcome 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Made my site very very slow’ is closed to new replies.