WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Made huge mistake

[Resolved] Made huge mistake

  • I’m not sure what I did but my site is totally haywire now. I can’t even log-in. I think I tried changing the default root URL to the page I wanted to be the “Home Page”. Now when I try to login, it redirects to http://domain/home/wp-login

    This is where my site is, http://collinrobert.com/

    So not only can I not login, but my site is haywire.

    I re-uploaded the theme via FTP. I even uploaded some WordPress files via FTP to solve the login problem.

    Hopeing to get back on track. Thanks – Collin

Viewing 6 replies - 1 through 6 (of 6 total)
  • Open your wp-config.php and add these two lines.

    define('WP_SITEURL', 'http://collinrobert.com/');
    define('WP_HOME', 'http://collinrobert.com/');

    Try to browse http://collinrobert.com/wp-admin/ after that.

    If you changed your site’s URLs from the Settings –> General page, you can revert them by accessing the wp_options table in phpMyAdmin.

    @engagewp

    It will be difficult for him to update that table data via phpMyadmin, as he have to search the option_key and update with proper option_value. config one will be easier.

    @the Grey Parrots

    Yes, this was just another option. Personally, I never felt it was more difficult to find the options table than it was to navigate FTP. If you’re a new, non-technical user, they’ll both be complex at first. The options needed are typically at the beginning of the table so finding them isn’t usually very hard and replacing them is just changing the URL. Either way will work, though. Here’s a link from the Codex on various ways to change them.

    http://codex.wordpress.org/Changing_The_Site_URL

    I tried Grey Parrots method and it worked, thanks!
    None of my content is showing. Is my site populating data from the wrong wp-content folder perhaps? I can see in my FTP folders that I have a folder with all my images but my site is wiped clean now.

    Link:
    http://collinrobert.com/

    Any help is appreciated!
    Collin

    Might be your database got changed.

    Kindly check your wp-config.php file whether your correct database is being configured or not.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Made huge mistake’ is closed to new replies.