WordPress.org

Support

Support » Themes and Templates » Made a simple theme. Dates not showing up in index.php's blog feed.

Made a simple theme. Dates not showing up in index.php's blog feed.

  • On my blog’s main page, when you glance over all of the blog post excerpts, only the newest and oldest two show “Posted on February 12, 2013 by admin under Uncategorized.” The rest just say, “Posted on by admin under Uncategorized” with no date.

    Is this something I can set in the Dashboard? Or will it be a tweak in index.php and/or functions.php? Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Christine Rondeau

    @crondeau

    Volunteer Forum Moderator

    I think that the index.php is mostly the cause here. It’s not in the functions.php and all posts should have dates, so nothing in the dashboard.

    Do you have a copy of the site that we could have a look at? Maybe there’s an error in the HTML source somewhere.

    You were spot on with suspecting that index.php was to blame. Editing that file ended up fixing everything. I found the issue being discussed on Stack Overflow, and the fix they suggested there ended up working.

    The code I ended up using for date, that now shows up on every post, is:

    <?php the_time('F jS, Y') ?>

    Hello. I am a bit new to WP but I am great at picking up things, including PHP, which i know enough to stay away from or to copy and paste it somewhere, LOL. I just incorporated a blog into my existing website: http://gratzergraphics.com/blog/

    The problem is that the “Leave a reply” from the 2012 theme puts that text above the post, which makes no sense. How could you comment before reading a post? If I move that to below the post, the text with the date disappears. I tried the fix mentioned above. I had put it in an h3 tag but it would not appear. Not sure what I’m doing wrong.

    FYI: I know HTML and CSS well but don’t program in PHP.

    OK. Of course, since i’ve been working on this issue for three days…now that I posted in this forum, I figured it out!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Made a simple theme. Dates not showing up in index.php's blog feed.’ is closed to new replies.
Skip to toolbar