Support » Fixing WordPress » MAC OSX & PHP 5.3.2 uploading images

  • Resolved keesdegraaff


    CANNOT UPLOAD IMAGES from computer.
    (from library an url is working o.k)

    I’ve Installed version 2.9.2 on a server with PHP 5.3.2
    Uploading from computer is not possible. The funny part is that it’s working properly on a window machine but not on my MAC OSX 10.6.3

    I’ve also installed WordPress 2.9.2 on a server with PHP 5.2.13. Where everything is working fine!!

    How can i solve this nasty problem?


    Working version: (PHP 5.2.13)
    login: admin
    pasword: testwp
    NOT working version: (PHP 5.3.2)
    login: admin
    pasword: testwp

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff


    Volunteer Moderator 🚀

    Try deactivating all of your plugins. If that resolves the issue, reactivate all plugins individually until you find the cause.

    If that does not resolve the issue, you may need to increase PHP’s memory limit, execution time, or file upload limit. Though this FAQ is not directly related to your problem, it does detail the necessary alterations:

    Thanx Moderator Macmanx

    1/ Not a single plugin is activated.
    2/ It’s working fine with PHP 5.2.13 but not with PHP 5.3.2
    3/ It’s working fine with windows, But not with MacOSX
    4/ It’s not showing the flash-uploader
    5/ It’s working fine if you choose the options: From URL or the Media-Library

    By default Worppress shows the flash-uploader (with a option to switch to a browser-uploader)
    All I get is a blank screen…….!
    (see screendump: )

    My own conclusion is that there is nothing wrong with my browsers, or the PHP settings of mij hoster.

    It’s a conflict between MAC- WordPress- ????PHP……???

    Before I start bothering my hoster, I like to locate the problem.
    Is that possible?
    And How?????
    I cannot imagine that I’m the only person who’s facing this problem (?)
    Actually, there is a other person here in Holland who recognized it.
    But we’re still not able to resolve it.

    So, Why doesn’t WordPress show the flash-uploader on my MAC when WordPress runs on PHP 5.3.2???

    And how can we locate this conflict?

    Kees de Graaff (Hoogland, Holland)

    Moderator James Huff


    Volunteer Moderator 🚀

    The only way to track down the problem is to start with basic troubleshooting. Did you try to increase PHP’s memory limit or execution time as suggested?

    The memory on the shared server is 32 MB. It is not possible to increase that. It must be sufficient, my hoster said.
    The max_execution_time is 15. It cannot be altered, my hoster said.

    Again: it is working with windows not with OSX

    Why doesn’t WordPress show the flash-uploader on my MAC when WordPress runs on PHP 5.3.2???

    Is there someone who has a clue?
    Are there other persons who have met the same problem?

    How the hell can i solve this.

    Which browser are you using on Mac?

    Acyually I’ve solved the problem.

    1/ I’ve changed some code in wordpress/wp-admin/includes/media.php
    line 1357-1360

    // If Mac and mod_security, no Flash. 🙁
    $flash = true;
    if ( false !== strpos(strtolower($_SERVER[‘HTTP_USER_AGENT’]), ‘mac’) && apache_mod_loaded(‘mod_security’) )
    $flash = false;

    I did remove the code in bold. Since then it did show the browser-uploader. Butt sill not yet the flash-uploader

    2/ I’ve downgraded Flash from flash-10 back to flash 9.0

    Everything is working fine now.

    Why it all is as it is? I wouldn’t have a clue…

    But i’m happy everything works fine.

    Your a legend for picking this up!

    I have a few websites and I couldn’t work out why some clients had issues with uploading images using a mac.

    Seems the issues I could find also was PHP 5.3.2

    Thanks so much. I followed the same steps you mentioned by deleting the bold text and it works.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘MAC OSX & PHP 5.3.2 uploading images’ is closed to new replies.