Support » Plugin: Modern Events Calendar Lite » M.E. Calendar Lite Fatal Error

  • I received an email about a fatal error caused by M.E. Calendar Lite. The error is:

    Error Details
    =============
    An error of type E_ERROR was caused in line 1211 of the file /home/site/yoursite.com/wp-content/plugins/modern-events-calendar-lite/app/features/mec.php. Error message: Uncaught Error: Cannot use object of type WP_Error as array in /home/site/yoursite.com/wp-content/plugins/modern-events-calendar-lite/app/features/mec.php:1211

    Stack trace:
    #0 /home/site/yoursite.com/wp-admin/includes/template.php(1345): MEC_feature_mec->widget_news(”, Array)
    #1 /home/site/yoursite.com/wp-admin/includes/dashboard.php(246): do_meta_boxes(Object(WP_Screen), ‘normal’, ”)
    #2 /home/site/yoursite.com/wp-admin/index.php(148): wp_dashboard()
    #3 {main}
    thrown

    WordPress version 5.4.2
    Current theme: OceanWP Child (version 1.0)
    Current plugin: Modern Events Calendar Lite (version 5.10.0)
    PHP version 7.4.3

    I have deactivated all other plugins and am still getting the error message. What can I do to fix this?

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, that was the json_decode error. Hope the developers fix that.

    • This reply was modified 1 year, 3 months ago by smrishad.
    Thread Starter frogbutt

    (@frogbutt)

    Another note:

    The fatal error seemed to occur only after (successfully) importing Google Calendar events. I have the exact same setup installed on another site and it is working just fine, although I did not perform any Google Calendar imports on that site.

    Plugin Author Webnus

    (@webnus)

    Hi All,

    Thank you for your report,
    This is forwarded to the developer team and it will be fixed for the next updates.

    Best Regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘M.E. Calendar Lite Fatal Error’ is closed to new replies.