Support » How-To and Troubleshooting » <p></p> and <br /> in posts not working?

<p></p> and <br /> in posts not working?

  • i searched the support forum and have found nothing(i posted about this in another thread but it was left unresolved)

    basically what’s wrong is that when I’m posting in WordPress whether it be editing an old post or posting a new post; paragraph and break tags in particular won’t work at all if I put them in. So if I put or <p></p> what happens is, when I save it, WordPress deletes them for I don’t know what reason u_u.

    I really want to know how to possibly fix this, because I didn’t have this problem in versions before 2.3. Or if this can’t be fixed, I would like to at least know why WordPress is deleting/not-picking-up/registering <p></p> and (because it’s seriously annoying when I want a paragraph or a break and it won’t go through)

    help would be much appreciated n_n

Viewing 15 replies - 1 through 15 (of 50 total)
  • I’m using WP 2.1 too but am facing the same problem. The way I resolve it is by adding a dot (.) and styling it white (same color as my background) so that it’ll appear as a <br>. I can’t find a solution to this either T_T

    Need the URL of your blog so I can view the source. Also, have to looked at your site in multiple browsers to see if its a rendering problem?

    I’ve the same problem on momboo.net/blog
    It’s not due to css or rendering problem, I think it’s something that involve your escaping procedure or the way you use to check the content of post.
    I save and continue editing and I see my <br> and my <p> </p> disappear, also if I edit a post without modifying the content and when i save the post all <br> and <p></p> disappears.
    One more advice for people dealing with this problem, try with <p> &nbsp; </p> and good luck

    Ehm, my page is on wp mu, not 2.1 but similar i thought

    If someone wants to check yet another site that is doing this, mine is peterennsonline.com. I would be glad to send someone the CSS stylesheet if they want to take a look at it.

    I am also having this problem.

    I’ve just discovered that this problem seems to stem from Apple’s Safari browser.

    If you are using Safari and have this problem, try using FireFox instead. I just did this and resolved this issue.

    hi, i don’t think it’s a browser problem… coz i’m using firefox and IE, and the problem doesn’t go away… even when i tried adding the ” ” but it still doesn’t work 🙁

    i meant, i tried adding &nbsp in between the <p> and </p> but everything gets erased after i save the post…

    Moderator kmessinger


    Forum Moderator

    Try Windows Live Writer. It is free so it is worth the try to see if your problems go away. It is definitely better than the WP editor.

    Usually though, from what I have been reading here, some non-compliant plug in causes the problem.

    I am also getting this on my site. I can’t go back and edit posts without wiping all my text formatting.
    I dont think its a plug in because I turned them all off and its still happening.
    Has anyone figured this out yet?

    Will upgrading to 2.3.1 version fix this?


    No, it won’t. I’m running 2.3.1 version and I still have this problem :/

    I’m having the same problem. I’m guessing the issue is a combination of the recent Safari upgrade and the recent WP upgrade. I can’t find a logical solution right now, but I’ve switched to Opera on my mac and it actually KEEPS the formatting instead of deleting it. This leads me to believe that the problem is browser-related, but firefox isn’t woring for me either.

    Try Opera and see if that works out for you, and then maybe we’ll get to a better solution later.

    coming back to this again.
    I’m still having this problem. and honestly it bothers me D:

    So what I know right now is that it’s not a browser problem. I’ve tried it on IE, Firefox, Opera, Safari, been on a mac been on a pc. and nothing has changed. Whenever I put
    or <p> where the line breaks are supposed to be in my post. they automatically disappear after I save the post.

    Oddly enough, when I switched to the WP default(or classic) theme, the <p> and
    were all automatically put in. This is incredibly odd because I’ve always been able to use my old themes on the new WP upgrades. Anyway, when i tried editing the default 2.3 theme to how it i wanted it to be with my original theme (and this took hours) it still didn’t work. (the <p> and
    ended up being deleted again).
    And just in case it’s still not clear what’s wrong here’s some screenshots:
    post formatting should look like this:
    but instead it ends up like this:

    and as others have stated. this also (i don’t think) isn’t a css problem.

    I only have on of the problems you face when posting in Safari (Mac). Firefox enables my posts to have paragraphs and breaks.

    But I have noticed comments do not have paragraphs although they do break lines.

    http://www.thedailydoug.com if you want to see what I mean.

Viewing 15 replies - 1 through 15 (of 50 total)
  • The topic ‘<p></p> and <br /> in posts not working?’ is closed to new replies.