<!more> In Feed (20 posts)

  1. tariqbamadhaj
    Posted 8 years ago #

    Before this version (2.5) of WP, it used to be that even when full feeds were selected, they would be cut off by the <!more> tag.

    With the latest version (2.5), this is no longer the case. I do not want full feed nor do I want summary that cuts it off before the <!more> tag.

    I would like an option to make the feed cut off at the <!more> tag instead. Could not find any plugin to do this. Any other recommendation?

  2. Edit the feed-rss2.php file. At the top you'll find this:
    $more = 1;

    Change it to zero to change the effect of the more.

    You may want to make the same change to the other feed files, like feed-atom.php and feed-rss.php.

  3. tariqbamadhaj
    Posted 8 years ago #

    Thanks Otta42.

    I have made changes to the following files:


    which were in the /wp-includes/ directory.

    Will report back in a few hours to see if it works :D

  4. tariqbamadhaj
    Posted 8 years ago #

    Just to confirm, after I make the changes, I should use Summary for text feeds right? Or should I be using Full?

  5. tariqbamadhaj
    Posted 8 years ago #

    I have changed

    $more = 1;


    $more = 0;

    for these files:


    I then went to Settings > Reading and changed For each article in a feed, show to Full text.

    I wrote a new article with the more tag, published it and went to look at the feed in my feed reader. It showed the full feed.

    So I went back to Settings > Reading and changed For each article in a feed, show to Summary.

    I wrote another new article which also has the more tag and published it. Went to the take a look at my feed reader and it only showed the first few sentences. That is, it cut off way before the <!more> tag.

    What am I doing wrong and how can I overcome this?

    I want the article to cut off at the <!more> tag for those that have that and for articles without the <!more> tag, to show in full.

    Any suggestions?

  6. You should be using full feeds. And the $more thing will take effect instantly, you don't need to wait "a few hours".

    If you're using feedburner redirection, then disable it temporarily so you can see the effect for real.

  7. tariqbamadhaj
    Posted 8 years ago #

    I am using Full feeds and deactivated my FeedBurner FeedSmith plugin which was the only feedburner redirection plugin I had.

    However, it still does not work and I am not sure why. I tried calling the feed with varius URLs like


    replace example.com with my site but it still shows the Full feed and does not cut it off.

    What could I be doing wrong?

  8. kmonty
    Posted 8 years ago #

    I'm having the same problems. I have FeedBurner set up as the main feed my readers use, so I don't want to temporarily disable anything about it.

    When I just check the WordPress feed (example.com/feed/), I get the same problem.

    I edited the files as you suggested (I found them in the wp-includes folder), and I'm still not seeing it any different. Any other suggestions would be much appreciated as I really liked the <!more> separator in the feeds before 2.5. TIA

  9. kmonty
    Posted 8 years ago #

    Does my theme need a WP function call to make this work... IE some plugins/features only work by having wp_header and wp_footer calls in the theme files?

  10. kmonty
    Posted 8 years ago #


  11. denixoid
    Posted 8 years ago #

    Yep! I would like an option to make the feed cut off at the <!more> tag too

  12. denixoid
    Posted 8 years ago #

    Please, help to cut the feed as it was in the 2.2 version

  13. Giorgos
    Posted 8 years ago #

    I had the same problem with the change of behavior regarding the use of the <!--more--> tag by the feed generators. I wrote a small plugin that reverts the functionality back to what we have been used to. It requires no configuration.

    The plugin is called more-feed-excerpt. The name could be better, but, well, it does the job :)

  14. denixoid
    Posted 8 years ago #

  15. rawalex
    Posted 8 years ago #

    What I want to know is why the heck was this functionality removed from wordpress? It was working fine, it provided exactly what the people using it needed, so why suddenly remove it?

    It is very frustrating to have to keep dealing with an API that appears to change randomly.

  16. Giorgos
    Posted 8 years ago #

    @rawalex: I agree with you, but it seems there are lots of people who want to deliver full-text feeds, while splitting the posts at the "more" tag on the web.

  17. MTO
    Posted 8 years ago #

    gnot, thanks for the plugin...
    Though it didn't work for me. I had full text feeds enabled, the plugin enabled, and when using more-feed-excerpt it was just showing the first X words, as default.

  18. kmonty
    Posted 8 years ago #

    Thanks gnot, but that wasn't what I was looking for either. I was hoping to get the exact same functionality from <!--more--> tag in web and in feed, not just switch to an excerpt when the more tag is present.

    I'll try the better feeds plugin now.

  19. Giorgos
    Posted 8 years ago #

    @MTO & @kmonty:
    The more-feed-excerpt plugin does exactly this: Splits the posts and feed entries at the exact point you specify in the document with the "more tag, only if you have set your blog to serve full-text feeds. If you set it to serve summaries, then you get an excerpt calculated by wordpress (the first N words), despite the fact the plugin is enabled. This is the plugin's functionality by design and it works (as expected) according to this concept.

    Here are some notes though, just in case any of the following has happened:

    I would recommend against using Firefox' Live Bookmarks to test this feature as it always shows the excerpt that is calculated by Wordress (first N words). Note that this excerpt always exists inside the feed, even if it contains the full text.

    Finally, temporarily disable any plugins that cache your content in order to test such features.

    Thanks for your feedback.

  20. teaaker
    Posted 8 years ago #

    I had this problem earlier, but it was because my feedburner feed url had a "/rss" at the end. Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic