WordPress.org

Support

Support » How-To and Troubleshooting » <!–more–> not working

<!–more–> not working

  • monkeynotes
    Member

    @monkeynotes

    I must be doing something stupid because I cannot get the <!–more–> functionality to work. WordPress just ignores it. I am using the standard install of 1.5 with the default template and “markdown” plugin activated.

    Anyone else having the same problem?

Viewing 15 replies - 1 through 15 (of 16 total)
  • James Huff
    Support Team Rep.

    @macmanx

    Does it work with Markdown deactivated?

    monkeynotes
    Member

    @monkeynotes

    Nope, it does not seem to work at all. I must have broken it somehow, but I really have not done that much to the template…

    Are any plugins interfering? Disable them all and try turning them on one at a time and see if the problem goes away. Try without any plugins working and see if it works

    I discovered the same thing with my fresh installation of 1.5

    However, it worked when I added a second post.

    First I just edited the default “Hello World” post, adding a <!–more–>, but WP ignored it.

    Then I created a totally new post, where I put a <!–more–> into it, and suddenly it worked on both posts.

    Don’t know why it does not work on the default post, but first work when new posts are added and updated….strange

    I found that the Acronym plugin messes with the “more” tag.
    so i just turned it off and everythings fine.

    monkeynotes
    Member

    @monkeynotes

    I have found the problem, kind of. My site is set up to only display one story per page – if I set it to display more than one story the <!–more–> thing starts working again.

    I thought I was going crazy. This is definately a bug. If you have one entry in the category the <!--more--> will not work. Also, if you follow the <!--more--> with <!--noteaser--> you will find that the “teaser” doesn’t even show in on the index page. Whoa! And I thought it was just me.

    Although it may be a bug for one single post, it’s one to make note of for a fix, perhaps. Still, how many blogs have one single post as the entirety of their site?

    New blogs do!

    This is not just a single post bug. It also occurs when displaying one post per page.

    Tahongawaka
    Member

    @tahongawaka

    I’ve just upgraded from 1.2, and have some posts that contain the <!--more--> tag. On the permalinked page for the post, I’m getting nothing above the <!--more--> but when I switched to some of the packaged themes for 1.5, the page is working correctly. I checked the differences between the two themes is that in my converted theme, the_content() was called with a second parameter, and the new themes only have one parameter. I removed the second parameter from my converted theme, and all is working now.

    See if this will fix your problem.

    Scott Reilly
    WordPress & Plugin Developer

    @coffee2code

    This has just been fixed in the repository; for those who wish to make the simple change themselves: http://trac.wordpress.org/changeset/2378

    @coffee2code

    that change isn’t working for me, though i suspect the problem has to do with misunderstanding the change set. If I understand it correctly, I am to change line 177 of the wp-blog-header.php file from this:

    if (1 == count($posts)) {  

    to this:

    if ( is_single() || is_page() ) {

    Additionally the change log seems to indicate some change on line 257, but the new code appears to be the same as the original, though there’s something weird with an additional blank, un-numbered line… Ignoring the line 257 confusion, and make the above change, all pages fail to draw with a php error reporting that the is_single() function doesn’t exist.

    Any suggestions?

    *bump*

    I’m using 1.2.2 (installed via Fantastico in my Cpanel) and I couldn’t get the more tag to work at all. Thankfully I found a plugin that is, imo, far superior, hide-or-cut-text, from http://www.coffee2code.com/wp-plugins/

    Anyone familiar with the lj-cut tag (LiveJournal) will be quite pleased with the ease-of-use. 🙂

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘<!–more–> not working’ is closed to new replies.