Support » Plugin: WooCommerce Pay Per Post » lst upgrade broke my site

  • Resolved opscraft

    (@opscraft)


    Last upgrade broke my site the error attached below. What should I do?

    [15-Nov-2019 00:15:32 UTC] PHP Fatal error:  Uncaught Error: Call to undefined method Woocommerce_Pay_Per_Post_Helper::can_use_woocommerce_subscriptions__premium_only() in /.../wp-content/plugins/woocommerce-pay-per-post/public/class-woocommerce-pay-per-post-restrict-content.php:95
    Stack trace:
    #0 /.../wp-content/plugins/woocommerce-pay-per-post/public/class-woocommerce-pay-per-post-restrict-content.php(220): PRAMADILLO\Woocommerce_Pay_Per_Post_Restrict_Content->check_if_purchased()
    #1 /.../wp-content/plugins/woocommerce-pay-per-post/public/class-woocommerce-pay-per-post-public.php(42): PRAMADILLO\Woocommerce_Pay_Per_Post_Restrict_Content->can_user_view_content()
    #2 /.../wp-includes/class-wp-hook.php(288): Woocommerce_Pay_Per_Post_Public->restrict_content('[et_pb_section ...')
    #3 /.../wp-includes/plugin.php(206): WP_Hook->apply_filt in /.../wp-content/plugins/woocommerce-pay-per-post/public/class-woocommerce-pay-per-post-restrict-content.php on line 95
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Matt Pramschufer

    (@mattpramschufer)

    I am terribly sorry about that! I just released a new version which addresses that issue. Can you please try to upgrade to 2.4.8 and see if that corrects your issue.

    Thank You. It work.

    Plugin Author Matt Pramschufer

    (@mattpramschufer)

    Excellent, I am glad it worked out for you. I apologize for the inconvenience it caused, I will try better next time!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.