Support » Plugin: LiteSpeed Cache » LS Cache keeps missing

  • Hi, I hope you can help. I tried to contact you through your website, but as I purchased LS cache through my webhost I’m not able to login to ask.

    I’m having some problems on one site only, and unfortunately it’s the one that brings in the money.

    I have 5 sites hosted on a VPS and 4 of them are working like a dream with litespeed cache. But one just doesn’t seem to be caching as it should be. It’s a woocommerce site. When I look at the network tab quite often the cache is a miss. It’s a relatively busy site and I also have the crawler running.

    It looks like the cache is expiring very quickly when it’s generated. I’ve set it to something like 7 days, but it only seems to last about 5 to 10 minutes at best. I also have the web crawler running to cache pages, but it too doesn’t appear to be working on the site.

    I don’t know what else to do and I hope you can help.

    Apologies to wordpress mods as I understand this is probably a premium question, but in my defence, I am using the free plugin that plugs into the premium offer.

    Thanks

    John

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello,

    I just check your site for 30 mins ~ish and it was cached for me. I see that the LS cache is Hit-ing and from the source code i can see:

    <!– Page generated by LiteSpeed Cache 1.9 on 2018-02-16 21:35:14 –>

    Still you can check from debug log if something is triggering purge of the cache.

    If you wanna speed up your page – try to reduce the JS and CSS script. You have a lot of them, optimize the images and clear the errors.

    Hi Tishu,

    It looks like the cache works on page reload, but not always when generated from the server-side cache, which is kind of the reason I paid for it. The log is showing a purge every 1-2 minutes (if I’m reading it correctly), but I’m not sure what’s triggering it. I can see a wp-cron running, but a cron is something I would expect, especially as I’m running xml imports and third party api calls.

    X-LiteSpeed-Purge: public,efd1_ 02/16/18 23:25:40.462
    X-LiteSpeed-Purge: public,efd1_ 02/16/18 23:26:59.137

    I’m aware of the js and css, but my hands are really tied on that front.

    When it serves the cache from the server it’s nice and fast, but it’s just not working as it should. I seem to get a very long initial render time when it’s not cached, but when it is cached it loads very quickly.

    With the previous version of litespeed when I was using it to optimise it was giving the long initial render. I disabled the optimisations and used fastest cache instead which solved that problem. But now it’s back to be weird and slow again

    • This reply was modified 1 year, 11 months ago by johnc1979. Reason: spelling and term errors

    I’ve been doing some more looking and found the following.

    Load homepage
    Go to another page such as the one in this thread
    Go to a product
    Go back to homepage.
    There’s no cache and everything has been purged. This happens no matter how quickly or long it takes between pages. It seems that if you go to a few pages and then a product page the cache gets purged. The moment the product is hit seems to be the problem

    This is the report number.

    Report number: FXJTSZTB

    Report date: 02/16/2018 23:04:05

    Plugin Support qtwrk

    (@qtwrk)

    hmmmmm , from source code I see

    <!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket

    are you using both or multiple cache plugins simultaneously ?

    I decided to dump the Litespeed plugin qtwrk. The cache being purged every few minutes without any support was unacceptable and I couldn’t leave it that way. WP Rocket appears to be doing the job correctly.

    Plugin Author Hai@LiteSpeed⚡

    (@hailite)

    As you mentioned, you saw a purge in log. Can you paste the related log snippet here? In that log I believe you can also find the purge reason. If you keep getting miss, that must be something that triggered the purge very often.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘LS Cache keeps missing’ is closed to new replies.