Support » Plugin: LiteSpeed Cache » LS 4.4. + WCFM = 100% CPU load

  • Resolved Bike Gremlin

    (@bikegremlin)


    After having updated LS to 4.4 (from 4.3), I started getting 100% CPU load on the server.
    It’s a shared (reseller to be precise) hosting environment – cPanel, LiteSpeed and CloudLinux.

    It’s a test website with 0 visitors.

    If I disable LiteSpeed plugin, CPU load drops to zero.
    Same goes for disabling the plugin:
    WCFM – WooCommerce Frontend Manager

    But if I keep them both running – 100% CPU load.

    I’ve tried enabling WP and LS logs – don’t see any errors.
    The same goes for browsing the website with the F12 view.

    LS works wonderfully on all my production websites, it’s the best WP caching plugin in my experience – but I’m not using WCFM on any production website (and I probably won’t, if I don’t figure out how to solve this problem 🙂 ).

    I’ve got the WP debug logs saved, along with LS logs – if it’s of any help.

    I can send a Dologin link if anyone on the LiteSpeed team is interested in figuring this out (not sure if it’s a common use-case).

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Hai Zheng⚡

    (@hailite)

    Thanks for the encouraging feedback and clear info.

    I tried WCFM but can’t reproduce. On which page did you meet the 100% CPU issue?

    Thread Starter Bike Gremlin

    (@bikegremlin)

    I happens on the entire website.
    Even when no one is visiting it.

    Very, very strange to say the least – haven’t seen anything like it ever.

    Suspected a DDOS, then some virus – but couldn’t find anything.

    Then I started the good old plugin disabling and found the culprit.

    Also, I know when the problem had started, so I was looking: which plugin did I update at the time. LS was the only one – nothing else was touched for days before.

    It may not be a LS problem – maybe the noted plugin has some “substandard code” or something (not sure, I’m not an expert, just thinking out loud).

    Thread Starter Bike Gremlin

    (@bikegremlin)

    Here’s a list of the plugins – huge, but it’s been tested for months and didn’t have any problems until recently (not that it’s a good idea for a production site).
    Disabling either LS, or WCFM solves the problem.

    Code Snippets
    Customer Email Verification for WooCommerce
    Easy WP SMTP
    Elementor
    Elementor Pro
    Essential Addons for Elementor
    Loco Translate
    Ocean Extra
    reCaptcha by BestWebSoft
    Srpski prevod na latinici
    The SEO Framework
    WCFM – WooCommerce Frontend Manager
    WCFM – WooCommerce Multivendor Marketplace
    WCFM – WooCommerce Multivendor Membership
    WooCommerce
    Wordfence Security
    Yoast Duplicate Post`

    Thread Starter Bike Gremlin

    (@bikegremlin)

    Switching the PHP version from 7.4. to 8.0 seems to have dropped the CPU load below 20%. Though it’s still not zero when the website is completely idle (no visitors whatsoever).

    Is there a set of PHP extensions (modules) that is necessary for the current LS version to function properly?

    Hi, i had the same problem. I solved with rollback to version 4.3 using wp-rollback plugin.
    After updating the litespeed cache to 4.4 mysql started sending multiple queries, causing CPU overhead.

    • This reply was modified 4 months, 2 weeks ago by marcosdgomes.
    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    @bikegremlin

    could you please create a ticket here in our system ?

    Best regards,

    Thread Starter Bike Gremlin

    (@bikegremlin)

    Hi @qtwrk
    Thanks for taking the time to look into this. 🙂
    I’ve just created a ticket.

    Thread Starter Bike Gremlin

    (@bikegremlin)

    Seems to be a hosting related problem – for all I can tell.
    Marking this as resolved.

    I.e. cloning the website to another server got it all working perfectly fine on that server. While cloning that clone back to the original site kept making problems with CPU usage.

    Will post info if I figure out the problem cause, in case anyone else runs into a similar problem.

    Thread Starter Bike Gremlin

    (@bikegremlin)

    Update:
    The latest LiteSpeed Cache plugin update (4.4.1) seems to have completely solved the problem.
    With the same hosting server setup.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.