Support » Plugin: Latest Post Shortcode » LPS does not list posts after i have logged out

  • Hi, i am using LPS on a website i made for a client and i have encountered a peculiar problem.

    When i am logged in the admin everything displays nice. Immediatly after i log out the content that should be listed trought LPS dissapears. Below the sequences.

    Have any of you had this problem? Can you help.

    The version of the plugin is 9.6.5

    <div class="main-post">[latest-selected-content limit="1" display="title,date,content-small" chrlimit="900" url="yes" linktext="Citeste articolul" elements="17" taxonomy="category" orderby="dateD" css="main-art"]</div>
    <div class="cleaner"></div>
    <div class="latest4">[latest-selected-content limit="5" display="title,date,content-small" chrlimit="75" elements="17" orderby="dateD" url="yes" linktext="Citeste articolul" css="main-four" show_extra="exclude_previous_content" ]</div>

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Iulia Cazan

    (@iulia-cazan)

    Hi,

    Do you have any cache plugins activated? Also, I was trying to access the site and it seems to be protected (or has a splash screen, so cannot assess).
    Have you tested the pages with removing completely that protection? Also, can you check if the posts you are seeing in the editor are not protected too for public access?

    Have a nice day,
    Iulia

    Thread Starter Boosuioc

    (@vasilecacat)

    Hi, i have no cache plugins activated, i’ve put up a maintenance screen because i could not leave the site displaying as it is. However, before asking for help i disabled all plugins and i still had this problem. the posts are not private, they are all published. I have disabled temporarly the maintenance screen so you can take a look. You will see that i get a big white space where the divs above and the shortcodes should be.

    Thank you

    • This reply was modified 1 month, 2 weeks ago by Boosuioc.
    Plugin Author Iulia Cazan

    (@iulia-cazan)

    You need to completely remove the “password protection” plugin from your system if that is what you are using. I know it has a bug and regardless of the fact that you disable it, it still hangs in there and alters the REST API responses. Give it a try.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.