Support » Plugin: Membership by Supsystic » Loved the Plugin, But …

  • Resolved claudio65

    (@claudio65)


    Firstly, I wanted to say that I loved this plugin.
    But I’m having trouble with some things.
    Setting up the plugin, accidentally delete the administrator role (I think the option to delete a role could be clearer).
    After that, I ended up deleting all the roles and recreating new ones, including the administrator.
    I discovered that you can not delete the role of “visitor” (I think there could be an observation stating this).
    Now on the users page, the “Find a user” box can not find users if the paper is selected.
    Only shows users when the “roles” box is marked “all”.

    Another problem is the name that appears on the cover.
    Unlike the user name, or the person’s name, what appears is the person’s email name before the “@”.
    Example:
    Email address: claudiopontocom@dominio.com
    Name on the cover: claudiopontocom

    And the “Pending Email Review” email also shows the same thing as the username.
    That seems to me to be a mistake too.
    If you can help, I appreciate.
    Thank you!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I made a new installation of the plugin because the first time I deleted the roles that come by default.
    To make sure this was not the problem, I do not change the roles this time.
    But I created a new role, I do not know if that would cause the problems I’m having.

    The problems are these:

    – When I edit “User Fields”, in “Profile” tab, all fields that I change the name (to my language), are automatically recreated with the original name again (in English).

    – The username always remains as the first part of the email of the person who is registering (before the ‘@’ – the username in the email domain). No matter what is written in the “username” field or in the “Nickname” field, what always appears is the part of the email before the “@” (eg: anything@domain.com = username “anything”).

    – After registering and being validated by the site administrator, when I try to log in I give an error message “Invalid login or password”

    My website:
    https://reforma.virtual.rio.br

    Plugin Author supsystic

    (@supsysticcom)

    Hi, @claudio65
    Thank you for contacting us regarding your question!
    Your comments are extremely important to us.

    When I edit “User Fields”, in “Profile” tab, all fields that I change the name (to my language), are automatically recreated with the original name again (in English).

    We could not reproduce it. Did you remember to save the changes?

    The username always remains as the first part of the email of the person who is registering (before the ‘@’ – the username in the email domain). No matter what is written in the “username” field or in the “Nickname” field, what always appears is the part of the email before the “@” (eg: anything@domain.com = username “anything”).

    After registering and being validated by the site administrator, when I try to log in I give an error message “Invalid login or password”

    Please contact us through our 
    internal support.
    We will help you to solve the problem.

    claudio65

    (@claudio65)

    Thanks for the reply, but I just gave up using the plugin.
    By the way, I’m practically giving up using WordPress itself.
    I tested at least three different plugins, and none of them worked 100% like I expected (or how they should work).
    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.