Support » Plugin: The Dude » Love the plugin

  • Love the plugin, no doubt.

    But for some reason when I turn it on. It switches my language for admin back end to English, same happens for all texts I translated to Dutch for the theme. While my client wants Dutch. When I disable the plugin. It switches back to the installed Dutch.

    Look into why it loads the wrong .mo file and you have got a winner. 🙂

    Best regards,
    K

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Kostas Vrouvas

    (@kosvrouvas)

    Hi, are you sure that this happens on the entire back end? Or just the “Howdy” message?

    I tested both 4.1 and 4.2 trunk on local-host, but nothing happens. It may be due to the function about that “Howdy” message, it’s the only “extra” code that differs from the “Hello, dolly” plugin, so this problem would have occurred with this plugin too.

    If you can, can you remove this code from the plugins php file, activate it and see if it happens again?

    I’ll replace this code anyway on 0.3 when I’ll add more quotes…

    // Replace welcome message
    function the_dude_welcome($translated_text, $text, $domain) {
        $new_message = str_replace('Howdy', 'His Dudeness', $text);
        return $new_message;
    }
    add_filter('gettext', 'the_dude_welcome', 10, 3);

    Thread Starter Kristof Loyens Quantum Leap

    (@quantum-leap)

    Hey Kostas,

    Yes, here’s a screenshot with the plugin disabled.
    link

    And here the plugin is enabled.
    You can see the change in language occurs aswell in the front- as in the backend of the language files.
    link

    Only difference is I activated and de-actived the plugin. Refreshed the page and took a screenshot.

    I installed the hello Dolly plugin just to see if it would happen there too. With the hello Dolly plugin the language loads correctly.

    I commented out the code you gave in the php file and now the text loads correctly when the dude plugin is activated.

    It seems thats resolved the problem i had.

    Thanks a lot!
    And again. What a great plugin. Love that movie. 🙂

    Plugin Author Kostas Vrouvas

    (@kosvrouvas)

    Thanks Quantum Leap, I’ll rewrite this function in 0.3 sometime soon, I hope there won’t be a problem again!

    Awesome movie!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Love the plugin’ is closed to new replies.