Support » Plugin: Sticky Back2Top Universal » Love the concept but still has a few bugs

  • For some reason it doesn’t want to work with Altitude Pro. It’ll show up once you scroll to the very bottom. And even then, it’s partially cut off by the themes widget are above…

    Let me know if you get this fixed. Would love to use it.

    I’m looking for a floating style Back2Top option. Not one that appears once you scroll all the way to the bottom.

    Also, if you add a new design, please consider a circle with the standard arrow.


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Michael Kastler


    Thanks for the feedback cientiros! I’ll take a look at the issues with Altitude – I would guess it impacts other themes with widgets too. If I can replicate and resolve it I’ll let you know 🙂

    The other two things you mention:
    * Configuring when floating back2top appears (e.g. N px from bottom, always)
    * New design, circle with arrow

    Those are on the punchlist for a next revision!

    Plugin Author Michael Kastler


    This was a totally dead easy fix – just needed to add z-index to the css in order to have it take precedence over the widgets and other content.

    v2.0.2 should have you covered; let me know how that works with Altitude Pro!

    I did add an arrow/circle image too, but there is going to be a major update soon that will have new images, text, shapes, and even the ability to adjust the arrow colors, so keep checking for updates.

    I appreciate the quick response. For some reason it still does the same thing. Maybe its conflicting with something else in my theme?…

    Plugin Author Michael Kastler


    Yes, that’s strange … I set z-index to 999, which should be enough unless your widgets are set to the same or higher number. The arrow should sit on top of anything that doesn’t have an explicitly layer position.

    Before anything else I’d try the obvious – change the arrow selected and save options, then clear your browser cache and review the page again.

    If that fails if you give me your website address with the plugin active I can dig a little deeper. Also, what browser you are using?


    I’m using chrome. It works just fine on the author pro theme.
    Thank you

    Plugin Author Michael Kastler


    I’m using chrome also, and don’t see any problems with any of the themes I’ve tested (including Altitude Pro).

    Can you give me your website address, with the altitude pro theme in place? Ideally with the plugin running too, but I understand if that’s not possible.

    Then I can dig into the visible styling and see if I can spot what pushes the arrow below the widgets … my guess is we could also resolve by increasing the .sb2t class z-value to 9999. If you are familiar with css you could try adding this, or changing it in sb2t-styles.css in the css directory of the plugin:

    .sb2t {
        z-index: 9999;
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Love the concept but still has a few bugs’ is closed to new replies.