Support » Plugin: Koko Analytics » Love Koko! Is it supported on PHP 7.4?

  • Resolved roam92

    (@roam92)


    Awesome plugin, thank you! Love how lightweight it is, and no unnecessary fluff…

    Quick question: Has the plugin been developed & tested for PHP 7.4? Wondering if it’s safe to upgrade my server while using it.

    Also, perhaps a small bug:

    When using the helpful “Last 28 days” stats view, after I hit “Refresh” on the browser, today drops off and then it becomes the 28 days *prior* to today…

    Thanks again!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Danny van Kooten

    (@dvankooten)

    Hey @roam92,

    Yes, PHP 7.4 is absolutely supported and it’s actually the first thing we test compatibility for because it is what we use ourselves.

    And thank you for bringing that to our attention, I would have overlooked that for years. Diving in right away!

    Danny

    Plugin Author Danny van Kooten

    (@dvankooten)

    Hey @roam92,

    I’m having some trouble replicating this issue, may I ask what timezone you are in?

    Hey Danny,

    Thanks for your fast response and the answers!

    Sure, I am in the U.S. Eastern timezone.

    My Koko settings are:

    – Exclude pageviews for all roles.
    – Do not use a cookie.
    – Default date period Last 28 days.
    – Automatically delete data older than 60 months.

    (The issue I described has actually happened for months, but I thought it would have been caught so haven’t reported it until now.)

    Really great plugin, thanks again! I love its attention to optimizing size & performance while maintaining focus on key features.

    Update:

    I see you just released a new revision of the Koko plugin, Version 1.0.13.

    I applied the new version and tested the reported issue, and am happy to report that it is now fixed!

    Every time I refresh the “Last 28 days” view, it now stays in place and no longer shifts the dates.

    Great work, thanks so much! 👍👍👍

    Plugin Support Harish Chouhan

    (@hchouhan)

    Hey @roam92,

    Thanks for the update.

    Plugin Support Lap

    (@lapzor)

    8<

    • This reply was modified 7 months, 3 weeks ago by Lap.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Love Koko! Is it supported on PHP 7.4?’ is closed to new replies.