Support » Plugin: Wordfence Security - Firewall & Malware Scan » Lots of URL with wordfence_lh indexed

  • Resolved aniki1980

    (@aniki1980)


    Hi

    In search console i have lots of errors under the duplicate title tags and metadescriptions section.

    The duplicate URL’s that i have are like this:

    https://www.example.com/page/3/?wordfence_lh=1&hid=7BE0B5F5F491F50049FA7565F16F22C9

    I tried to remove the URL’s from search console, no index them in robots.txt and adding the URL parameters “wordfence_lh” and “wordfence_logHuman” to do nothing in the URL parameters section of search console, but they keep coming back even when i uninstalled the plugin 2 months ago.

    What i have to do to fix this problem once and for all please?

    • This topic was modified 1 year, 6 months ago by aniki1980.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @aniki1980!
    Do you have any cache on the website? If so, have you tried clearing that cache?

    Thanks,

    I have the same issue of having pages with “wordfence_lh=1&hid=LONGRANDOMNUMBER” being indexed by Googlebot, and I was hoping to see a satisfactory answer to the OP by someone from Wordfence.

    Sorry to say that, @wfasa, but I’m afraid your answer is not satisfactory, as it says nothing about the issue of why Googlebot is finding these URLs to navigate in the first place. You may have had the best of intentions, but…

    Do you have any cache on the website?

    C’mon, who doesn’t have a cache on their website?

    The question we need an answer to is:

    “why is Wordfence generating empty URLs and what can we do to avoid it”

    I would appreciate it if you or someone else from Wordfence could elaborate on the issue, at least to the point of clarifying:

    1) Do these Wordfence empty URLs create any security problem? Can someone seeing these random numbers use it somehow to undermine Wordfence protections?

    2) Empty URLs result in ranking dilution. Is there any way Wordfence could indicate to Google and other search engines that those empty URLs are not supposed to be indexed?

    Thanks,
    CB

    Hi @cbrandt

    Try this.

    Go to Wordfence > All options > Enable live traffic logging OFF and then “Amount of live traffic data to store (number of rows ) = 0

    I just did that and looks the URL’s google was indexing don’t exist anymore. I’m not sure if that’s that because yesterday i asked for help at Wordfence’s premium support but they didn’t answer yet.

    At least i’m clicking on all the duplicate URL’s i have and now they show nothing. Not sure if it’s luck or there’s something else. Try that and tell me if it works please.

    Hi @aniki1980,

    Thank you for the tip. I’m afraid however that I can’t live without Live Traffic 🙂

    Let’s see if someone from Wordfence comes with a explanation and solution for this issue that does not imply turning off Live Traffic.

    As for the URLs showing nothing, this has always been the case with my wordfence_lh URLs, they generate an empty, blank page, as far as visible content goes. But this is not the same as not having the URL being generated/indexed at all.

    Thanks,
    CB

    Hi again!
    It’s possible that your website does not serve the wordfence_lh link correctly. It should be serving an empty page. However, sometimes themes use the WordPress template redirect hook incorrectly which results in all requests with a query string end up serving the full contents of the page. This would cause Google to think there is a full copy of your page under that URL.

    In your example, the /page/3/ should not be part of the URL, so that also raises questions about how your home_url was apparently reported incorrectly at some point. We construct the URL using WordPress home_url which should under all normal circumstances be the sites base URL and not anything containing page/3/ etc.

    The reason I ask you to clear cache is that if there was a temporary problem which has now been resolved, clearing cache could be a very simple fix. If the problem persists after that, further investigation would be required.

    If you browse to the wordfence_lh URL do you get a full page, or a blank page?

    Thanks,

    Hello

    If i enable Wordfence plugin, when i click on one of those URL’s i get a blank page.
    If i disable the plugin, i get a full page with some posts similar like clicking on one category.

    Hi @aniki1980!
    Can you please send me a diagnostics report from Wordfence? Navigate to Wordfence > Tools. Select the Diagnostics tab. At the top, click the button that says “Send Report by Email.” Change the email address to asa@wordfence.com and please provide your username or ticket number so I know who the mail is coming from.

    Thanks in advance!

    • This reply was modified 1 year, 6 months ago by wfasa.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Lots of URL with wordfence_lh indexed’ is closed to new replies.