• Resolved msdesignfoto

    (@msdesignfoto)


    Ok, I have been using the plugin for a while now, and its really great.

    But….. Yesterday night I noticed, in the mobile view, there were 12 related products… TWELVE!!

    So, after a few tests, I realized the JS and CSS optimizations I made were affecting the carousel of products, regardless of the settings I tried in all plugins.

    Having at least one of these optimization plugins active would cause the carousel to show all the 12 products at the same time, on pc, tablet or mobile. Yes, 12 products in the same line. In mobile. Thats ugly to see.

    The issue is related to Autoptimize and Async JS, both from the same author. It was enough for me to have 1 of these plugins active, it would break the carousel, no matter the options they have selected. I tried turning on the JS option in the carousel but it did not work. Sadly, I had to deactivate the plugin for now and use the default related products from WooCommerce.

    I just wanted to leave a feedback here.

    Cheers

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Dan Zakirov

    (@alexodiy)

    Hello @msdesignfoto

    You can add an exception to Autoptimize and it should work. The author of this plugin has already answered this question, here

    Just add an exception. The slider script itself is negligible, it does not particularly affect the page load speed

    Thread Starter msdesignfoto

    (@msdesignfoto)

    Thanks !

    I added both the plugin and the js path, but doesn’t work..

    Plugin Author Dan Zakirov

    (@alexodiy)

    This is not due to the Autoptimize plugin, through ?ao_noptimize=1 you still have errors in the console. Diagnostics is required.

    Also I think this is because of “defer = ‘defer’” – try async or eliminate it altogether

    Thread Starter msdesignfoto

    (@msdesignfoto)

    Ok I managed to do it.
    I placed the names of the 4 scripts belonging to the carousel instead of the path. Now it works great. In the first second the page loads, I can see the whole 12 products at once, but after that, it replaces the view with only 4 products.

    Many thanks!

    Plugin Author Dan Zakirov

    (@alexodiy)

    Disable initialization after loading the whole page and you will be better

    Thread Starter msdesignfoto

    (@msdesignfoto)

    Sorry to ask, but where do I set that option, under what plugin?
    I checked Carousel options and I see none with that name.

    Plugin Author Dan Zakirov

    (@alexodiy)

    Thread Starter msdesignfoto

    (@msdesignfoto)

    Oh I thought it would be that, but I didn’t notice any difference. Anyway, the final output is ok, and that is enough!

    Thank you again!

    Plugin Author Dan Zakirov

    (@alexodiy)

    It just depends a lot on your theme and the plugins you use.

    If you liked our plugin, you can leave a review here, this additionally motivates us to make the plugin better.

    Thanks for using.

    Thread Starter msdesignfoto

    (@msdesignfoto)

    Cheers!
    I already added my review before this issue 😀

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.