WordPress.org

Forums

  1. Okoth1
    Member
    Posted 3 years ago #

    Warning: Invalid argument supplied for foreach() in /home1/xxxx/public_html/blog/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 838

    Warning: array_diff() [function.array-diff]: Argument #2 is not an array in /home1/xxxx/public_html/blog/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 839

    Warning: Invalid argument supplied for foreach() in /home1/xxxx/public_html/blog/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 840

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home1/xxxx/public_html/blog/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 1160
    class="hide">

    Fresh install (twice)

  2. keesiemeijer
    moderator
    Posted 3 years ago #

    Seems the sexybookmarks plugin is not compatible with WordPress 3.2

    http://wordpress.org/support/topic/troubleshooting-wordpress-32-master-list

  3. Orakel78
    Member
    Posted 3 years ago #

    Works fine with my WP 3.2. Do you use the new WP template ?

    I've got a custom one that's not updated with WP so that might be the reason it's working for me.

  4. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    @keesiemeijer sexybookmarks should be compatible with WP3.2. We have many users on it, including our own blog.

    @Okoth1 we're about to release an update.

  5. keesiemeijer
    moderator
    Posted 3 years ago #

    @Orakel78 and @shareaholic
    Sorry ,just reading the warnings. Shouldn't have said it wasn't compatible.

  6. Shareaholic
    Member
    Plugin Author

    Posted 3 years ago #

    Latest version (v4.0.4.1) release today. Please upgrade ASAP!

  7. Okoth1
    Member
    Posted 3 years ago #

    Thanks for the update, but the errors in the options page are now these:

    Warning: Invalid argument supplied for foreach() in /home1/xxxx/public_html/xxxx/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 904

    Warning: array_diff() [function.array-diff]: Argument #2 is not an array in /home1/xxxx/public_html/xxxx/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 905

    Warning: Invalid argument supplied for foreach() in /home1/xxxx/public_html/xxxx/wp-content/plugins/sexybookmarks/sexy-bookmarks.php on line 906

  8. ankur_shareaholic
    Member
    Posted 3 years ago #

    @Okoth1 Please try resetting the settings after updating to the newest version.

    Please let us know if still get any warnings/error.

    Thanks !!
    Ankur

  9. Okoth1
    Member
    Posted 3 years ago #

    Sorry, the last errors are still there. Could it be a conflict with another plugin?

  10. Okoth1
    Member
    Posted 3 years ago #

    Sorry, the last errors are still there. Could it be a conflict with another plugin?

  11. ankur_shareaholic
    Member
    Posted 3 years ago #

    Okoth1: Please provide me the url of your wordpress site.

    Please check if you used the reset settings button shown in the image.
    Reset Settings

    Reset settings button will reset all the settings.

    When you press reset button, it will ask for your confirmation. Press yes.

    Please let us know if still getting error. Sorry for the inconvenience.

    Thanks !!
    Ankur

  12. Okoth1
    Member
    Posted 3 years ago #

    Hi Ankur,

    I pressed the reset button, but it won't ask for a confirmation and the errors remain.

    I'll activate the plugin tomorrow morning (Indian time) since it is American oriented and there are lots of errors on the front side. America will be sleeping then.

  13. ankur_shareaholic
    Member
    Posted 3 years ago #

    @Okoth1 , When you press the reset button, page reloads and then at the top of the page there is one line asking your confirmation for restting

    In that option select yes. Currently your settings are not reset, you are half way down.

    Please check and let us know.

  14. Okoth1
    Member
    Posted 3 years ago #

    Thanks for your perseverance, Ankur. I totally missed the confirmation at the top. The error messages are gone now. See what this plugin can do.

    Thanks

  15. Okoth1
    Member
    Posted 3 years ago #

    One other this is this message:

    Load Time Optimized To Fix: Simply re-save your SB settings.

    It remains red.

  16. ankur_shareaholic
    Member
    Posted 3 years ago #

    @Okoth1 Try saving by clicking the save settings button at the botton.

    Repeat the step 2-3 times to check whether the button turns green.

    If face any problems, please let us know :)

    Cheers !!
    Ankur

  17. Okoth1
    Member
    Posted 3 years ago #

    Yep that did the trick. All green now. Thanks Ankur.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic