Support » Fixing WordPress » lots of 404s for loadingAnimation.gif

  • Since updating to 2.9.2 I am getting lots of 404s for loadingAnimation.gif file in my logs

    The exact request is:
    GET /wp-admin/wp-includes/js/thickbox/loadingAnimation.gif HTTP/1.1

    and the referer for those request is: (notice the double slash)

    I have been trying to replicate it by adding/editing media to the library and adding/editing posts while watching in Firebug but I could not. Anyone has any idea please what is causing this? Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I just have this happening again and now I can reliably replicate it.

    Steps to produce (in visual mode):
    – Add a gallery with a couple of images as described in
    – After inserting gallery if one uses “Edit Gallery” then 404 described above occurs. How can I correct this? Thanks



    Forum Moderator

    Are you using any thickbox plugins? Is thickbox incorporated into your current theme?

    Many thanks for your prompt reply. I have only default plugins Akismet and Hello Dolly, not activated. My Theme is Mystique 2.3.1 by digitalnature



    Forum Moderator

    Try re-uploading the wp-admin/include/js folder from a fresh download of WordPress.

    I just downloaded and unpacked a fresh zip, but I do not have a wp-admin/include/js folder so I reuploaded


    folders and their contents to replace existing ones on the server. The problem still exists.

    Thanks again. I appreciate you time and help.



    Forum Moderator

    You’re right – there is no wp-admin/includes/js. I was getting mixed up with the wp-includes folder.

    Try re-uploading the entire wp-admin & wp-includes folders from your fresh download.

    Yes! that seem to have solved it. Thank you very much for your time and wisdom. Live long and prosper.



    Forum Moderator

    Glad to hear that your problems have now vanished. 🙂

    I am afraid the symptom is back.

    When one first clicks on “Posts”, a request to loadingAnimation.gif is made successfully. Then when “Edit” is clicked (in quick menu under posts title) another request is made, again successfully. Then, (assuming, the post has a gallery) When “Edit Gallery” icon is clicked, a series of requests are made. One of these is to http://domain/wp-admin/wp-includes/js/thickbox/loadingAnimation.gif (notice the wrong path, there is an extra wp-admin) which fails with 404.

    This is definitely a bug in wp-includes/js/thickbox/thickbox.js in the way the relative URL is used, because if one changes the line 9

    var tb_pathToImage = "../wp-includes/js/thickbox/loadingAnimation.gif";


    var tb_pathToImage = "../wp-includes/js/thickbox/dummy.gif";

    Then that last failing request changes to http://domain/wp-admin/wp-includes/js/thickbox/dummy.gif (again notice the request URL), but of course so as the first two originally successful requests since then no such gif exists.

    When in post edit mode ../ is falling into root directory and the call to ../wp-includes/js/thickbox/dummy.gif is successful. When gallery popup is displayed however ../ is insufficient and we are falling into wp-admin, hence the request to wrong URL http://domain/wp-admin/wp-includes/js/thickbox/loadingAnimation.gif

    Finally, changing the line 9 to

    var tb_pathToImage = "../../wp-includes/js/thickbox/loadingAnimation.gif";

    resolves the problem, as well as other requests not breaking, though I don’t understand how or why and I am not sure if this will have other side-effects.



    The above solution did fix the problem for me.

    It could be your server/host. They might be limiting your memory

    I ran across this problem and found that this has been discussed in the WP bug tracking system. There is a suggested solution that plugin developers should follow, and you can easily implement the fix yourself if you know a little PHP. See the thread here: (The fix is in comment #11)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘lots of 404s for loadingAnimation.gif’ is closed to new replies.