WordPress.org

Forums

[resolved] Lots of 404 errors (7 posts)

  1. cleanenergy
    Member
    Posted 9 years ago #

    Whenever I click on any of the 1.categories 2. "previous entries" 3. About 4. and various other spots (but not including the links, which I entered manually), I get a 404 error, saying the link is bad. These links are created automatically, I think, when I set up my wordpress blog. I'm thinking that somehow the links are bad, but I don't know how to fix it. I've tried changing themes, but that may have little to do with the problem and didn't help anyway.

    I appreciate any comments or help.

  2. yosemite
    Member
    Posted 9 years ago #

    You should post a link when asking for site help.

    I'll go ahead and assume it's the one in your profile (had time to look). It looks like a mod_rewrite issue. When you set up permalinks did a .htaccess file get written? Can you post the contents of that here? (between backticks to retain formatting)

  3. cleanenergy
    Member
    Posted 9 years ago #

    Thanks for responding. I wasn't sure if it was ok to put up a link to the site. It's http://www.interenergysolutions.com/blog. I don't know that a .htaccess file was created; I've looked in the past and been unable to find one anywhere, and just looked again. However, I also did not go through a specific process to set up "permalinks." I'm using WP 2.04, if that says anything useful.

    thanks very much

  4. yosemite
    Member
    Posted 9 years ago #

    Can you test with the default theme? See if you get the same results?

  5. cleanenergy
    Member
    Posted 9 years ago #

    Yes, I tested with the default theme, plus the Classic theme, plus other themes that I downloaded (I had the same thought, that maybe it had to do with the thems). But it's the same result no matter what.

    thanks much

  6. yosemite
    Member
    Posted 9 years ago #

    However, I also did not go through a specific process to set up "permalinks."

    What is selected on your Options:Permalinks page?

  7. cleanenergy
    Member
    Posted 9 years ago #

    Thanks very much for the help on this. I think you laid your finger on the problem. I went to the Options:Permalinks page and found the second item was checked -- not the default setting. Some time ago I had attempted to install a plug in; it said the that the settings on the page had to be seet to something other than default. So I changed it, but then I got a message saying I needed to update the .htaccess file, but could never find it.

    So long story short. Thank you very much. Except for one small problem -- which I hope to be able to address myself -- this should be resolved now. You're awesome.

Topic Closed

This topic has been closed to new replies.

About this Topic