Support » Plugin: MailPoet - emails and newsletters in WordPress » Lot of calls to the plugin

  • Resolved amedic

    (@amedic)


    After the examination I have noticed that there are lots of calls to the plugin.
    Why is this happening, how to reduce them?
    Is it better to use previous version, regarding the speed?

    Thank you.

    • This topic was modified 2 years, 3 months ago by amedic.
    • This topic was modified 2 years, 3 months ago by amedic.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author MailPoet

    (@wysija)

    Hello @amedic,

    Well spotted! MailPoet 3 may indeed make more requests than MailPoet 2 did, however that is done for a good reason – to allow you to send emails faster and more reliably.
    Doing so does require making periodic requests to send out emails, however even slower hosts should be able to handle it.

    You can read more about how it works and the options MailPoet offers here: https://beta.docs.mailpoet.com/article/129-what-is-the-newsletter-task-scheduler

    Best regards,
    MailPoet Team.

    I suspect my issue is the same.
    Since my Mailpoet plugin auto-updated 6 hours ago, the CPU usage on my server has tripled (albeit still not high).
    Even though my Mailpoet scheduler is set to “Visitors to your website (recommended)”, I’m now getting the following logged in my server access log at approx 20 second intervals:
    “GET /?mailpoet_router&endpoint=cron_daemon&action=run&data=eyJ0b”
    Please advise?

    Plugin Author MailPoet

    (@wysija)

    @conorsboyd today’s release includes sending optimization, which requires some changes to the data structure. You are probably seeing a temporary background process that’s migrating old records, which can take some time on a site with a large number of subscribers/newsletters sent. Once done, everything should be back to normal.

    Thanks for replying.
    I appreciate hearing that there is some reason why today’s update is causing this behaviour.
    I am using it on a number of sites.
    However, the site in question has exactly one subscriber, and no newsletters yet.
    6 hours later, still seeing log entries every 20 secs.

    Doesn’t seem right?

    Plugin Author MailPoet

    (@wysija)

    @conorsboyd could you please see if this solution works?

    Adding those two lines to mailpoet.php doesn’t seem to have made a difference, no, unfortunately.

    Is the timezone reference in that other post likely relevant to my issue?
    This site is probably set to a timezone UTC+12 whereas the server is set to UTC.

    Plugin Author MailPoet

    (@wysija)

    Please try to:

    1) Disable the plugin for a minute and then re-enable to rule out any stuck processes.

    2) Change task scheduler option to “MailPoet” and then back to “site visitors”.

    If these steps don’t help and cron is consistently accessing your site every 20 seconds, then please get in touch with us directly.

    Thank you.

    me too. hits every 20 secs. or so.

    followed @wysija steps above but still every 20 seconds – immediately after today’s update to 3.6.1

    I’m ashamed to say but this is on BlowDaddy hosting.

    I’ve disabled for now.

    • This reply was modified 2 years, 3 months ago by Brian North. Reason: 1st Post is always Beta & non-subscription

    Thanks @wysija, have tried both of those, and it’s still behaving the same.

    Will contact you directly.

    Plugin Author MailPoet

    (@wysija)

    We can confirm that this is indeed an issue and will work to resolve it as soon as possible. Thank you to all who have reported this. Please stay tuned for a fix!

    Nice work, thanks for the update. 😉

    Same Issue here. The 3.6.2 Update kill our Server. This is a big Problem for us! Our Server goes down every 5 Minutes. Please hurry up this is serious!

    GET /?mailpoet_router&endpoint=cron_daemon&action=run&data=eyJ0b2tlbiI6IjRhNjVhIn0 HTTP/1.1

    • This reply was modified 2 years, 3 months ago by Thomas Rinkl.

    The 3.6.2 Update kill our Server

    sorry i meant 3.6.1., the 3.6.2. update is not shown in wordpress yet

    I think I’m experiencing the same issue. My server is highly overloaded. This started when I update the plugin. Now I have disable it!

    Plugin Author MailPoet

    (@wysija)

    Please try updating to MailPoet 3.6.2.
    3.6.1 still has the issue where an incompletable scheduled task may cause high resource usage. The problem has been fixed in 3.6.2.

    We have noticed that for some sites the 3.6.2 update is not offered for some reason, so you may have to perform the update manually, by downloading the update from the plugin repository and uploading it to your site.
    We’re still looking into why the automatic update may not be offered.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Lot of calls to the plugin’ is closed to new replies.