WordPress.org

Forums

Subscribe2
[resolved] Lost Subscriber List, Fatal Error on Re-install (10 posts)

  1. ant_in_wales
    Member
    Posted 7 months ago #

    Hello
    After a happy year with S2 - where I got up to 50 subscribers for a minority interest! - I had a problem with S2 not sending out emails.
    In what I now learn was a bad move, I thought I'd uninstall and re-install it.
    The first thing I noticed was that my subscribers were all gone.
    I am still upset by this, but there we go, I didn't backup.
    Are they definitely gone for ever?
    I can now install S2, but when I try to Activate, I get a "fatal error".
    Can anyone help me out please?
    The people of Aberystwyth are waiting for more restaurant reviews!
    Best wishes
    Tony

    https://wordpress.org/plugins/subscribe2/

  2. tanaylakhani
    Member
    Plugin Author

    Posted 7 months ago #

    Hi,

    uninstalling the plugin, does remove all the data associated with it. You can restore it from backup if you have one, or check mail logs to retrieve their email addresses.

    Which fatal error are you receiving?

  3. ant_in_wales
    Member
    Posted 7 months ago #

    Thank you for the reply - I understand you don't develop it anymore and appreciate the effort.

    How can I recover from mail logs.
    Will there be a Sent Items folder somewhere so I can copy the last working one?

    Program seems to install OK.
    When I press Activate I get "Plugin could not be activated because it triggered a fatal error."

    Warning: require_once(/home/aberevpf/public_html/wp/wp-content/plugins/follow/classes/class-s2-core.php) [function.require-once]: failed to open stream: No such file or directory in /home/aberevpf/public_html/wp/wp-content/plugins/subscribe2/subscribe2.php on line 69

    Fatal error: require_once() [function.require]: Failed opening required '/home/aberevpf/public_html/wp/wp-content/plugins/follow/classes/class-s2-core.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/aberevpf/public_html/wp/wp-content/plugins/subscribe2/subscribe2.php on line 69

  4. mattyrob
    Member
    Posted 7 months ago #

    @ant_in_wales,

    Actually, it's me (MattyRob) who is no longer developing the code - I'm still here a little on the forums to pick up some issues I am aware of that Tanay - the new developer will be learning in the coming months :)

    The error pasted above means you are also using the 'Follow' plugin:
    http://wordpress.org/plugins/follow/

    It was a fork of Subscribe2 over 2 years ago and has not been maintained. It essentially duplicates a huge amount of the Subscribe2 code and makes minor changes so the front end form is more like the Follow button on WordPress.com. Sadly Follow and Subscribe2 cannot be used at the same time so uninstall one of them and you'll be fine.

    As for the lost data, you could ask if your hosting provider can restore the wp_subscribe2 table for you from a database backup (presuming all of your subscribers were Public Subscribers). If you had some Registered Subscribers too you'll also need the the wp_user and wp_usermeta tables but restoring those might have some unintended consequences as they store other data too.

  5. ant_in_wales
    Member
    Posted 7 months ago #

    Oh yes, I see
    Well, that's disappointing, but there we are.
    I've removed Follow and it's working fine now, thank you.

    Do you think the list but recovered from a Sent email?
    The email to subscribers must be in a Sent folder somewhere, surely?

    Thank you

  6. ant_in_wales
    Member
    Posted 7 months ago #

    One final question - I'm trying to add my Subscribers (I've got emails from 15 of them)
    I add them to the text box, click Subscribe, but nothing happens.
    I'm surprised I can't do something that simple.

  7. mattyrob
    Member
    Posted 7 months ago #

    @ant_in_wales,

    I add them to the text box, click Subscribe, but nothing happens.

    Where? There are quite a few text boxes created by Subscribe2.

  8. ant_in_wales
    Member
    Posted 7 months ago #

    On The Subscribers page.
    It says "Add/Remove Subscribers"
    Then "Enter Addresses, comma separated"
    Then a text box (where I put email address)
    Then Subscribe and Unsubscribe buttons.

    I add an email address, press subscribe, but nothing

  9. mattyrob
    Member
    Posted 7 months ago #

    @ant_in_wales,

    What version of Subscribe2 are you using now then> I've just tested on one of my sites and it worked fine. The page reloads with the box empty but over the top of it I got a message box saying "Address(es) subscribed!"

  10. ant_in_wales
    Member
    Posted 7 months ago #

    Curses!
    Thought I'd got rid of Follow, but I had de-activated, not Deleted.
    Completely Deleted, and now adding new accounts fine.

    Sorry for being a bit thick, and thank you very much for your help.

    Have a fine weekend

    Tony

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.