Support » Plugins and Hacks » Easing Slider » [Resolved] Lost slideshow when activate homepage as static page

[Resolved] Lost slideshow when activate homepage as static page

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author MatthewRuddy


    Hi @sabuk013, you’ll need to insert the shortcode [easingsliderlite] into your static homepage within WordPress. Have you done this?

    You may alternatively have to directly insert the Easing Slider PHP function into your static page’s theme file, depending on your setup.

    I’ve insert this code into my header.php

    <?php if ( function_exists( “easingsliderlite” ) ) { easingsliderlite(); } ?>

    Where do I find the static page’s theme file?
    I use WordPress 3.6.1 and TwentyEleven theme… :S

    Plugin Author MatthewRuddy


    It completely depends on the structure of the theme and how it has been coded. However, if you’re static front page is using the same header as other pages, you should still be able to see the slideshow.

    Can you link me to an example? I’ll take a quick look for you.

    I have to correct my request: slideshow works, when I activate homepage as static page…this is not the main problem.
    But when I order the slideshow to work only at homepage and activate as static page the slideshow become lost.

    My Code in header.php looks like this:
    <?php if ( is_home() && function_exists( “easingsliderlite” ) ) { easingsliderlite(); } ?> <?php

    Link to my wordpress site?

    Plugin Author MatthewRuddy


    That’s because the static page you’re setting may not be considered the homepage, hence is_home() is returning false and you’re not seeing the slideshow.

    Do you see the slideshow when just using the code below inside your static home page theme file?

    if ( function_exists('easingsliderlite') ) {

    <?php if (is_front_page()

    Should be work.


    Yes! It works!
    Thanks for your help.

    I’m glad it helped. ^^

    Plugin Author MatthewRuddy


    Awesome, great stuff. Didn’t think at is_front_page() would work for this application – my apologies!

    Marking this as resolved 🙂

    That’s the great benefit of forums with several people 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Lost slideshow when activate homepage as static page’ is closed to new replies.
Skip to toolbar