Support » Fixing WordPress » Lost Post and Page Edit ability and text?

  • Resolved bobkeenanphoto


    My site looks fine and is behaving well.

    But when I tried to add a page I could add a title and publish it but I could not add text, html, or media. Same with a post. Then I check existing posts. The all look fine on the site but on the edit page there is no text or media. The other weird thing is that the visual tab is highlighted but the text tab is greyed out.

    I turned off all my plugins…. no change.

    Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Christine Rondeau


    Volunteer Forum Moderator

    You may want to do a manual update and ensure that you updated ALL of the WordPress files.

    If that doesn’t work, try switching to the Twenty Twelve theme and see if the problem persists.

    Thanks for the suggestions. But I read somewhere else about installing a google libraries plug-in. I tried it and it worked. So what in the heck caused the problem and how is it that this plug-in fixed it?

    BTW when the java security scare was going on I disabled all java and java script capabilities on all of my browsers….. would that have anything to do with this?

    Christine Rondeau


    Volunteer Forum Moderator

    Yes, disabling javaScript would have totally done it. Without javaScript the entire web falls apart.

    Just so you know Java is to javascript what ham is to hamster.. They are totally different beast.

    Java is used by big enterprises like Oracle and IBM and cost millions. There’s none of that in WordPress.

    Thanks for the javascript info. But. I went back and turned javascript back on. Restarted my browser. I tried this on safari, firefox, and Chrome. Then I deactivated the Use Google Library plugin. And everthing was blank again on the edit pages. I reactivated the google library plugin and everything is good again.

    So what caused this? Is this plugin a good enough fix and should I relax and be happy?

    I still don’t know what caused the problem but here are two things that fixed it.

    1. “Use Google Libraries” plugin fixed it right away.

    While that fixed the problem I knew that what was really going on is that it was bypassing my WordPress libraries for the data it needed to load the data. That bothered me. So I did some more digging. And found that this other method permanently fixed the problem with my WP

    2. FTP’d into my files. Deleted the wp-admin and wp- inlcudes files ( note that i downloaded both first in case i needed to go back). Then with the latest copy of wordpress I uploaded the wp-admin and wp-includes files. Now the post edit window works and I do not need to run the use google libraries plug in

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Lost Post and Page Edit ability and text?’ is closed to new replies.