Support » How-To and Troubleshooting » Lost Paragraphs Bug in Safari

Lost Paragraphs Bug in Safari

  • WordPress [2.3.1] editor doesn’t create paragraphs correctly in Safari [3.0.4]. The problem appears to be rooted in converting the visual contents to code as this procedure will demonstrate:

    Create a new post. Select the CODE tab. Type three short paragraphs separated by newlines. Choose VISUAL tab and note that paragraphs are preserved. Now select CODE tab again. Text becomes one paragraph (no visible tagging).

    The act of switching from VISUAL to CODE or saving the post (which must do an implicit VISUAL2CODE) wipes out the paragraphs. This does NOT happen in Mac Firefox [].

Viewing 13 replies - 1 through 13 (of 13 total)
  • I’ve experienced this problem as well, with earlier versions of WordPress, using earlier versions of Safari. It hasn’t just appeared with the latest versions.

    I also have the same problem, on some WordPress installed on my webserver and on WordPress.com.
    I hope WP will resolve it soon.


    I also have the same problem with Safari 3.0.4 and WP 2.2
    It seems to be due to new version of Safari which implement now WYSISYG editor. I didn’t have the problem before.

    Some help ????

    Although not an answer- a workaround.

    Find your ‘tiny_mce.js” file, it is in ‘wp-includes/js/tinymce/tiny_mce.js’

    Line 7572, you need to change:

    // if ((tinyMCE.isGecko || tinyMCE.isOpera || tinyMCE.isSafari) && tinyMCE.settings.force_p_newlines && e.keyCode == 13 && !e.shiftKey) {


    if ((tinyMCE.isGecko || tinyMCE.isOpera) && tinyMCE.settings.force_p_newlines && e.keyCode == 13 && !e.shiftKey) {

    (Edited from: http://ijneb.com/archives/2007/10/13/safari-3-wordpress-2-tinymce-and-paragraphs/)

    Line 7572 in that file is the last line, in WP 3.2.1! The line 33 fix fixed my safari Version 3.0.4 (5523.10). Don’t blame the WP folks, it’s all the previous bugs in Safari that made the Moxiecodeguys go wild with their exceptions.
    Svenskjävlar förstås! lol

    The line 33 fix fixed my safari Version 3.0.4 (5523.10).

    My line 33 seems good… and the fix wilcosworld posted is already uncommented, and taking out tinyMCE.isSafari doesn’t seem to make much diference, but it didn’t work either way, so… more help?

    WP 2.3.2
    Safari 3.0.4 (5523.10.6)

    I am also having this issue still – any word?

    I have made the above edit to the tinyMCE section as well. That didn’t work. The line 33 hack in the thread above (changing the setting to false):

    this.isSafari = false;

    seems to do it, though.

    Has anyone seen any negative results to this?

    Having the same problem, saving the post and opening it againg with going to the code tab does the same thing. This bug sucks ass and should have been corrected along time ago!

    I found a workaround for Safari deleting paragraphs.

    Compose the post in “Code” and enter 10 (yes ten!) returns at the end of every paragraphs. These are recognized as a paragraph break and a double space in the post is the result.

    I made the line 7572 and the line 33 hacks shown above. I rebooted my server, then on different computers I erased my cache and restarted safari.

    Still won’t show carriage returns. No difference at all. Anyone know why. This is a real deal breaker.

    Using Safari 3.1 and WordPress 2.33

    Has anyone tried this with 2.5?

    In WordPress 2.3.3 + Safari 3.1, this fix (from http://www.lost-in-code.com/28/wordpress-safari/) worked for me:

    Find lines 4025 and 4026 in wp-includes/js/tinymce/tiny_mce.js:

    if (tinyMCE.isSafari && this.formElement)
    this.formElement.innerText = htm;

    and comment them both out:

    // if (tinyMCE.isSafari && this.formElement)
    // this.formElement.innerText = htm;

    This problem seems to have been solved for me in WordPress 2.5 + Safari 3.1 (5525.13).

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Lost Paragraphs Bug in Safari’ is closed to new replies.
Skip to toolbar