Support » Plugin: Restricted Site Access » Lost Options With Multisite Network Activation

  • I’ve a few multisite ‘sites’ on one with version 5.0 I get 6 options to select from:

    1) Allow search engines to index this site
    2) Discourage search engines from indexing this site
    3) I would like only logged in users to see my blog.
    4) I would like only logged in users who are registered subscribers to see my blog.
    5) I would like only administrators of this blog, and network to see my blog.
    6) Restrict site access to visitors who are logged in or allowed by IP address

    On my other multisite install I just get options 1,2 & 6. I’m missing options 3,4,5. On this site I’m running version 5.0.1 BUT it was only giving 1,2 & 6 with 5.0 anyway. This is all with WP 3.5.1.

    AH – as I’m writing this I think I’ve figured out what might be causing the problem. For the second site I’ve network activated it (the first site I’ve not). I think this is somehow limiting the settings presented on all the sub sites. Which is odd because I’ve had to specify option 6 above on all sub sites else they are actually visible if someone accesses directly to that sub directory.

    Is this how it’s supposed to work when it’s network activated?

    http://wordpress.org/extend/plugins/restricted-site-access/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I Deactivated Network activation and activated it per site – makes no difference I just have the following three ‘Visibility’ options below rather than the options I used to have as listed above.

    1) Allow search engines to index this site
    2) Discourage search engines from indexing this site
    Note: Neither of these options blocks access to your site — it is up to search engines to honor your request.
    3) Restrict site access to visitors who are logged in or allowed by IP address

    Basically this means that any member of my front MS install who is logged in can access all of my MS sites. This isn’t how it used to function and I cannot find in the change log that these changes have been made?

    Am I missing something here?

    I’ve got the same problem.

    On a multisite all registered users can see all Blogs. But I only want to see them their specific Blog.

    Did you solve it or did you use another plugin for that?

    Hi Raum, to better define ‘privacy’ for a multisite blog try this one:
    http://wordpress.org/plugins/more-privacy-options/
    It works for me.

    Hi Clive,

    thanks for that. This plugin would work, but now I don’t have the possibility to define my own Login-Page.

    Any Idea for that?

    Sorry, I’ve not tried to alter the login page so I’ve not made any changes to it or tried to.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Lost Options With Multisite Network Activation’ is closed to new replies.