Support » Requests and Feedback » Lost my weblog after upgrading to 2.9.1

  • CkS-Boss


    My blog:

    Something very wrong happened! I cannot find my blog anymore!!

    I uploaded the entire 2.9.1 folder to my ftp server with the appropriate config.php and my template folder as well.

    After I run the upgrade link I got ERROR msgs like these:

    Parse error: syntax error, unexpected T_STRING in /var/www/html/CKS_Blog/wp-includes/pluggable.php on line 1626

    Parse error: syntax error, unexpected T_STRING, expecting ‘,’ or ‘;’ in /var/www/html/CKS_Blog/wp-includes/script-loader.php on line 632

    Parse error: syntax error, unexpected T_STRING in /var/www/html/CKS_Blog/wp-includes/taxonomy.php on line 2304

    I finally decided to upload the entire 2.9.1 folder to my server again…

    I have tried to upprade the application as usual.. But this time I was redirected to an installation box (not upgrading box!). So I did it! After this done I got an entire and empty new WordPress blog! — without my previous content and without my previous template…!!

    I am trying to upload 2.9.1 again and again, but I’m afraid I won’t find my blog! Hundreds of documents lost?

    I’d appreciate any help on this.



Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi


    Your blog content should still be safe in your database (have you checked your database recently?). It sounds like you mis-configured the wp-config.php file when you re-uploaded the entire 2.9.1 folder. Check that file and edit it to point to your existing database.



    Hello esmi,

    Thank you for your help.
    I’m really sad. I think I have lost it all 🙁
    I think that the INSTALL process erased the database.
    Where is located the database anyway? Where should I check it? In the server where I have the website and the weblog databse, or are there content files in some other server (like a WordPress server?)

    Please have a look into this email exchange with my hosting service:

    Hello Antonio –

    In looking over your files and database, it appears that by doing an “install” rather than an “upgrade”,
    you have deleted the files from your old blog, as well as cleared out the databases from the blog. The program did not realize that you already had information for a blog and so went through and deleted the files you had previously used.

    Perhaps a bit late, but WordPress does offer a guide on upgrading your blog, rather than installing.

    Unless you have a backup copy locally, it is not possible to restore your blog to it’s previous situation (before the “mess”).

    Thank you

    Karen Higgins / EchoEchoPlus Hosting, LLC

    —– Original Message —– From: “Antonio Cerveira Pinto” <>
    To: <>
    Cc: “Antonio Cerveira Pinto” <>
    Sent: Friday, January 08, 2010 2:48 PM
    Subject: CkS Blog – some Help please


    I have tried to upgrade my WordPress http://www.chroma-kai- to version 2.9.1
    Something went wrong and I lost any contact with my weblog’s content and template!

    I did upload WordPress new files as usual, but I got instructions to INSTALL, not to UPGRADE, the blog afterwards, and so I did…

    It was a big mistake! After I did this I was prompted to take the following user name and pssword:


    The result was an entire new empty blog homepage! And no way to go back to my lovely blog!

    Trying to circunvent this problem so that I could access to my blog’s content I introduced new data on the settings page of the “new blog”, like giving a new name to the WordPress folder. It’s previous name was “CKS_blog”, and then I gave this new one: “Exemplo”.

    Finally, when I try to go to my Echo2Plus hosting server to see what is happening I get this warning from Firefox: “This Connection is Untrusted” !

    Now I think it is time to call for help!

    1) Have I lost my weblog content?
    2) If not how can I get it back?
    3) Is it possible to restore my blog as it was before I got into this mess?

    Thank you,

    Antonio C-Pinto



    Hi again,

    I actually have the entire blog database in Echo2Plus server that hosts my website and weblog content!

    But I don’t know how to upgrade the blog. Should I try to go back to the previous version of WordPress? I have a backup with me…





    I finally got to do the upgrade my blog for Word Press 2.9.1 all over again. And it works… but only for showing the homepage:

    I can only see the home page alone and without images, though. All internal links are dead, and worse than that, I cannot access to the administration area of my blog to sort things out!

    After I login to WordPress here

    using “admin” as login and my password for this blog

    I get this page

    that says: “You do not have sufficient permissions to access this page.”

    Would anyone help me to solve this charade?

    Thank you





    I finally recovered the entire blog access except EDITING MODE. This means that I cannot post, edit, or change settings, etc…

    When I try to login as follows:

    Login: admin
    Password: (…)

    This is the answer:

    You do not have sufficient permissions to access this page.

    PS: I think some string related to the password setting is corrupted. When all this mess began (I have INSTALLED the 2.9.1 version on a previous installation, instead of UPGRADE; and then I got a new passoword and new blog, not my previous blog! etc…) I made some changes in the login name and password for the unexpected new blog installation that I don’t remember anymore! So he I am stucked!

    Anyway, some strong ALERT should be sent to every WordPress users explaining that if one INSTALL a new WP version over a previous version that is already running one’s blog and database (when what we want is to UPGRADE a previous version), something fatal can happen!

    Some troubleshooting on this matter should also be on the WordPress front page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Lost my weblog after upgrading to 2.9.1’ is closed to new replies.