Support » Installing WordPress » Lost everything w/updating to 3.4 HELP!

  • Hi NuB here so please be patient with me… when attempting to update we lost everything, including the ability to log in using the link from Network Solutions. I did do a back-up, however, not everything got moved over properly so it appears. I have all of our images and news feeds downloaded to my computer, but the wp files appear to be corrupted. I also saved a copy of the blog file on the server by naming is blog_old.

    I contacted Network Solutions and they had me try to repair the installation first due to fatal errors when trying to update to 3.4. After several failed attempts and I even moved the wp files manually over from the backup, Network Solutions suggested that I do a reinstall back to the last time we updated which brings me back to 2.9.1.

    The update still fails with this error: Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 4920517 bytes) in /data/0/0/5/156/5971/user/6103/htdocs/blog/wp-includes/http.php on line 1363

    This was just one of many fatal errors, but it’s the most recent. another one was indicating that the theme twenty ten was missing the css file and when I moved it back over, it worked to log in again, but when I updated to twenty eleven, it said the same thing and I could not log in again as I did not have a saved version of that css to move over. I downloaded the twenty ten theme again and tried to switch back, but lost everything again.

    Can I go back to the saved file on the server? Although to me it appears that not all the wp files are there and if they are corrupted what would be the benefit to doing this except to get my blog pages, gallery and feeds back and do the update manually?
    I am not so concerned with the theme at this point as I can recreate it easily since I know how to write CSS files.

    I have downloaded the files to do a manual install, but I am a web designer not a programmer. I have been told by Network Solutions that if the manual update does not work then I need to reinstall the MySql database? HELP!

    I take direction well, but I am not familiar with the terminology for programming. Such as an “Open Directory”, what does that mean? An empty file on the server? And that is the first instruction in the manual deployment of the update!

    Ok, I’m calm, really, but how would I get my stuff back up without having to do it all manually again? We have over 5200 pictures and news feeds…. thanks for any help you can offer, really!

    Thanks, Tamra <3

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Fatal error: Allowed memory size of 33554432 bytes exhausted

    Try increasing the memory available to PHP.

    Ok,How or where do I go to do that?



    Forum Moderator

    Please see the post at the link I gave above.

    Oh Sorry. I will take a look there then. Thank you!!!

    Well, it looks like the database was corrupted along with the blog upon the update attempt. Thanks for the help, but I have someone helping me that knows a bit more about this than I do, so this thread can be closed I suppose.

    I will have to put the blog back together manually. bummer….

    Upon reading more about this particular update situation, it seems that a bug got into the update process that deletes files. I won’t be counting on an outside backup system anymore!

    Now onto learning more about programming and in particular WordPress!
    Cheers! Tamra



    Forum Moderator

    it seems that a bug got into the update process that deletes files

    what bug?

    Thanks for link above for the update as it worked. However, now I get this error:

    Fatal error: Call to undefined function self_admin_url() in /data/0/0/5/156/5971/user/6103/htdocs/blog/wp-admin/includes/update-core.php on line 698

    Any ideas as to what this one means?

    To esmi, I think the bug appeared somewhere in one of the plugins as they stopped updating and I couldn’t delete them. I am going to be ubber careful of what I add now…


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Lost everything w/updating to 3.4 HELP!’ is closed to new replies.