[resolved] Lost Categories in Import of WordPress.com (17 posts)

  1. enkerli
    Posted 5 years ago #

    Repeatable and rather tricky. Potentially requiring database fiddling..

    Working with WordPress 3.0.1 Multisite (created through either cPanel 11 or a manual install from WordPress.org, there doesn't seem to be a difference). The network works fine.

    I export the WXR from WordPress.com and import that file in a subdomain site on the network (blog.example.com). When the upload is done, the main content shows correctly but a few things don't work: categories, tags, links. These were imported, but they don't show up in association with the posts or in their own backend menus.

    I've noticed a few posts which talk about fixing this through the database, but they're not specifically about multisite and I'm not that experienced with phpMyAdmin.
    One solution I've seen talks about adding a post with all categories and then run some SQL query to get the tags back. A problem I have is that, though some categories do show up in the post-editing interface

    Did someone else have a similar experience?

  2. I've noticed a few posts which talk about fixing this through the database, but they're not specifically about multisite

    It will be the same process.

    Can;t say I ever had that issue myself tho.

  3. colegota
    Posted 5 years ago #

    I tried different ways to import my old independent blogs into new multisite installation.

    Finally my best results was a combination of WP tools and feedwordpress plugin. While this implies you need a second temp website online.

    I did exported pages (not post) using WP Import tool. Then categories and tags were included there.

    Then I created a copy of the blog (the whole WP Multisite, in fact) in another domain I have for test (let's say test-example.com / blog1.test-example.com).

    I've imported pages (with categories and tags) to blog1.test-example.com.

    I've installed FeedWordPress plugin in blog1.test-example.com and syndicate blog1.example.com with the option to link to local copy of the posts. That's like clone the blog itself.

    Same for the rest of the blogs at example.com in test-example.com

    Then removed old single site installation at example.com and installed and configured WP 3.01 multisite.

    Created again blog1.example.com as site blog1 in example.com super admin.

    Imported same pages with cats and tags file at blog1.example.com. And install FeedWordPress plugin.

    Syndicate blog1.test-example.com in blog1.example.com. And so on.


    .- RSS feeds does not inform about category hierarchies, but if they are imported previously they look OK. If you import posts first, you need to arrange hierarchies later.

    .- I have to do it with several blogs by several authors, anyone with different working rules. Some times tags are imported like categories, while you can easy export to tags again with inside tool.

    .- I don't know how to migrate links and link categories. Export and Import tables seems to be risky because id's changes. But some authors has a lot of links with descriptions, images...

    .- I also needed to move my main blog that originally syndicate the others blogs with FeedWordPress plugin. I did follow the same steps that for individual blogs but importing RSS from same domain. That's in the second step you syndicate example.com with all blogs there as the latest step. Then you choose between turn off syndication and change to sitewide tags plugin to synchronize to main blog or keep using FeedWordPress to feed main blog from author's ones.

    .- I have some individual post from authors with no blogs at main blog. I did imported it also with FeedWordPress and the feed for each author.

    I understand that it's a very special case in my side, but hope it can help.


  4. enkerli
    Posted 5 years ago #

    @Colegota: Wow! Congratulations on making it work and thanks a lot for sharing!

    I hope I can find a somewhat simpler method. I'll probably try yours, especially since I only have a few blogs to import. But it seems like there should be a more straightforward solution. Got some indications that it might be an issue in MySQL.

    And it's not specific to Multisite after all. I tried a WXR import on a fresh (not network-enabled) WP install and the same issue occurred.

    What would rock is if WordPress.com could give us other export options. Say, the .sql and wp-content folder.. Hey, one can dream. Can't one?

    Still, I'll try your workaround when I get a few hours to spare.

  5. What would rock is if WordPress.com could give us other export options. Say, the .sql and wp-content folder.. Hey, one can dream. Can't one?

    They way they are set up it woudl be nigh close to impossible. Or for pay. ;)

  6. enkerli
    Posted 5 years ago #

    They way they are set up it woudl be nigh close to impossible. Or for pay. ;)

    That's the thing! It's a service for which I would gladly pay. I'm already paying for the Offsite Redirect. I'm even trying out VaultPress (on another blog). Of course, one-time fees aren't as advantageous as recurring ones, but this kind of service would make a lot of sense. Especially given the time I wasted trying to make the import process work.

    Ah, well..
    Guess I'll try Colegota's workaround or wait for some magic to happen from the database wizards.

  7. colegota
    Posted 5 years ago #

    I think future versions of import/export plugin will fix those issues.

    I've tested to do with it at first different times with different problems. Has difficulty to have categories correctly assigned to posts. And later I did try to unify categories between author blogs and main page before migrating, and there is some reports about one possible problem cause. In fact, after change, edit and redesign categories tree the import gives just a few of original categories imported and fails when try to modify it.

    I understand this is the moment when many people start to migrate massively from multiple blogs to multisite and our experience will be useful for others.


  8. sydlow
    Posted 5 years ago #

    I've found the problem and have a workaround.

    WordPress.com exports posts with a tag of
    "<category domain="category" nicename="travel"><![CDATA[Travel]]></category>"

    This format isn't recognised by 3.0.1 wordpress. It needs the category in this format:

    So the quick way to fix this is open the xml export file from wordpress.com in a global search and replace in your favourite word/text editor that can support wildcards. eg
    Just search for "<category*"> and replace it with "<category>" and then do the import into your wordpress.org blog.

    Important: make sure you do this for just the posts items in the XML file and not the categories section.

  9. enkerli
    Posted 5 years ago #

    If this works, I'll be very happy! Do you have a tip jar, somewhere?

  10. enkerli
    Posted 5 years ago #

    It worked! Thanks a lot for this, Sydlow!

    Did it in Notepad++:
    Find what: <category.+">
    Replace with: <category>
    Regular expression
    (Replace all)

    Two things, though.
    1) All my post tags have been converted to categories. So I'm running the converter to convert most of them to tags. It's actually kind of ok, because I needed to clean these up.
    2) It didn't solve my problem with links. But since I can export them as OPML (and they didn't include much metadata anyway), it's also ok.

    Another thing which only has to do with the fact that I was reimporting from within an active blog: I had the YOURLS to Twitter plugin on, so I received a ton of notifications from that through two devices and through my cellphone. Kind of funny, actually.

    Anyhoo, I'm really glad to have received such a valuable workaround. I wasted quite a bit of time on this.

    Thanks again, Sydlow! I'm serious about the tipjar..

  11. sydlow
    Posted 5 years ago #

    Hey - glad it worked for you too. So it's a real workaround now!
    I can't believe wordpress folks hadn't picked this bug up. Surely we can't be the only people that are migrating from .com to .org

    If you export from your .org site you'll see the exporter writes out both formats of the category item.

    Thanks for the tipjar offer - but I've had lots of help from others on the Net over the years. Just glad I can put some back into the interweb.

  12. enkerli
    Posted 5 years ago #

    I've had lots of help from others on the Net over the years. Just glad I can put some back into the interweb.


    And Automattic really should do something about this. Not only are we not the only people migrating from .com to .org, but there's even a "business model" issue.

  13. Jon Cave
    WordPress Dev
    Posted 5 years ago #

    Posting this here now in case anybody else stumbles across this thread.

    If WordPress.com is using the 3.1 format then you'll want to use the development version of the importer.

    Found here and direct download link here.

    I can't believe wordpress folks hadn't picked this bug up. Surely we can't be the only people that are migrating from .com to .org

    Agreed. This is a pretty big issue so will see what can be done about pushing a release here.

  14. Has anyone reported the issue in trac?

    Not to be a bitch, but the forums are support, and NOT how you report bugs :) Go to trac.wordpress.org, sign in with the SAME ID and password you use here, and tell 'em. Now you're a debugger too! :D

  15. enkerli
    Posted 5 years ago #

    @Ipstenu: I think it has indeed been reported, at some point. I didn't look through trac because my purpose in posting here was to find a quick workaround. I was losing a lot of time on this issue and needed a quick fix. It eventually did come up through this thread. Thanks again, @sydlow!

    Of course, I get why you would emphasize the difference between bug reporting and support forums. I've read esr's "smart questions" rant like anybody else, way back when. But, I must say, this thread is a good example of how support forums are supposed to work. Plus, there are several situations in which there can be a "division of labour" between those who ask support questions and those who transform key issues into bug reports.

    I do have some experience beta testing and troubleshooting, but this was actually a support issue.

  16. My reply was to Jon, not you, actually. More people complaining that something was missed... doesn't help. Propose solutions, share your code on trac, and be pro-active. That helps :)

    I may be a volunteer moderator, but that doesn't make me any more 'support' than you. Seriously! The vast majority of 'support' here are people who like to help. Many times I DO make the trac tickets, but I try to ONLY do it when I can reproduce the error, since if more questions come up, I'll be able to help. If I can't repro it, then all I do is make more middle men.

    You call it a support issue, and that's fine. But I'm here to welcome you as part of the support team now :)

    So. Yes, look here for a fix, but now that you have one, it would be nice if you would give back a little more and trac up. A quick search of http://core.trac.wordpress.org/search?q=import+categories&noquickjump=1&ticket=on didn't show me any, but since I don't have a wp.com blog to play with this for you, it would be NICE if you could open a ticket :) If it's a dupe, it'll get closed. If not, someone will look at it.

    Thank you :) And yes, I mean that very sincerely.

  17. gadgetronica
    Posted 4 years ago #

    I just exported my WordPress.com blog (www.delgadoarts.wordpress.com) and imported to self hosted WordPress.org site (www.delgadoarts.com) and in the process, I had a weird issue with categories that I easily solved so I thought i would post for anyone who might run in to this exact situation.

    After importing, I could view the categories in the DASHBOARD > POSTS > CATEGORIES section. But, when I went to add the CATEGORIES option to the widget bar, it found 0 categories. I tried a couple of fancy category plug-ins, but nothing located my existing categories. I noticed in the Category review page, it listed 0 posts for each of the categories. But, if I looked at the Quickview of each post under POSTS > ALL POSTS, I could see that the posts were all assigned correctly. So, after some experimenting.

    I found you can uncheck all the categories under Quickview of any one of the posts (be sure to note which ones were actually selected for that post so you can correct this later). Hit SAVE.

    Then check all the categories in the Quickview in that same post and hit SAVE.

    For some reason, this relinks the categories and gets the Category list to recognize them again.

    If you have the category widget in your sidebar, you should be able to view all your categories again. Now, you'll want to go back and return your post back to its correct categories.

    So glad it was an easy fix and I hope I save someone else some headaches, too!

Topic Closed

This topic has been closed to new replies.

About this Topic