Support » Fixing WordPress » lost categories after 2.6 upgrade

  • Hello All,

    I was still on version 2.1 of WP. I upgraded using fantastico after I deactivated my plugins. All went well, except I have no categories for my post or my links.

    Suggestions?

    Thanks,

    bcp

Viewing 9 replies - 1 through 9 (of 9 total)
  • Apparently all the tags also went missing. 🙁

    The same thing happened to me (I was upgrading from 2.2.2), but I was able to install the Auto Tag plug-in to add tags to my older posts so that wasn’t too big a deal. I can’t find a plug-in to add categories retroactively, otherwise I wouldn’t be bothered too much, but I have a lot of posts and had loads of categories so I’d rather not have to go back through all the posts one by one.

    I too have lost categories – when I view the categories sections in admin I get a long list – with no names of cats – but tells me how many post are linked to the name less categories. Also categories missing from my archive page.

    I really want them back I do not want to go through it all again.

    Erm, I found this error as well. But was fixed when I uploaded a new .htaccess
    Which I think I’ve accidentally deleted when I was upgrading.
    Good luck trying ^^

    My .htaccess is empty. No code at all in there. Even my old backup is the same. Restoring the old (empty) .htaccess didnt work either. Is there supposed to be something in the code there?

    Any help would be great!

    mrmist

    (@mrmist)

    Forum Janitor

    Do a quick search as there are posts detailing how to fix the problem.

    If you have the option to restore, you can upgrad via version 2.3 and it would be ok.

    Actually, I found this article, and it worked perfectly!

    http://blog.cumps.be/wordpress-26-upgrade-fix-missing-categories/

    a friend of mine wrote these lines of code to do it automatically:

    update wp_term_taxonomy, wp_categories set description = cat_name where term_id = cat_ID
    update wp_terms, wp_categories set name = cat_name, slug = category_nicename where term_id = cat_ID

    am not really into coding, but maybe it might help someone

    Where, do I insert that coding?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘lost categories after 2.6 upgrade’ is closed to new replies.