WordPress.org

Forums

[resolved] Lost admin access (11 posts)

  1. mkirkwag
    Member
    Posted 6 years ago #

    I set up my site and was all set to tell the audience that it was there, right after I did this one...last...thing...and I killed it.

    What I was trying to do was make a static post. Here's where my descriptive powers are going to fail, because I can't look at what I was doing, but it was something like this: in settings, there's a place to specify what address of your site is and what you want the landing place to be if not the root site. At least I thought that's what it meant.

    I set the second address for a page that I wanted use as a home. Nothing changed. When I went to main address, it still went to the blog. So I tried changing the first address from http://www.tribeofadmins.com to http://www.tribeofadmins.com/home.

    Well. All the formating is gone, and /wp-admin redirects me to the blog. I tried http://www.tribeofadmins.com /home/wp-admin, but the result was the same.

    Do I need to reinstall WP and start over, or is there an element I can replace? Thanks in advance - I'm leaving hair all over the floor.

  2. WordPress Hosting
    Member
    Posted 6 years ago #

    You will need to update all links to new url in your database "wp-options" table

  3. mkirkwag
    Member
    Posted 6 years ago #

    Sorry - don't know how to find it. I've found a whole pack of "options-" files in the public_html>wp>admin file. I was looking at "options-permalink.php" and noticing this:
    include('admin-header.php');

    $home_path = get_home_path();

    and wondering if the url should be in that path, but given what happened the last time I started fooling around with settings, I didn't want to try it without asking.

    If that's not the right place, would you mind directing me to the "wp-options" table?

  4. mkirkwag
    Member
    Posted 6 years ago #

    I should have said - there is a file WP>Admin> options.php... I thought that was the right one, but expected there to be a url within it, but there isn't, and I don't see where one would (probably due to gross ignorance).

  5. mikey1
    Member
    Posted 6 years ago #

  6. mkirkwag
    Member
    Posted 6 years ago #

    Here's something else I wonder: shouldn't all my WP files be contained within one folder within the public_html file? There are 3 WP folders - admin, content, and includes - in the public_html folder. Then all the other WP files that don't live in one of those folders are loose in the public_html folder.

  7. mikey1
    Member
    Posted 6 years ago #

    Hi again, what you've described is correct, you have installed wordpress in your route directory public_html.The three main wordpress directories, plus all the individual wordpress files, including config.php.
    you'll need to edit the site url and blog url to reflect this.
    http://www.tribeofadmins.com/
    as explained in the links above.
    hope you get there.
    mike.

  8. mkirkwag
    Member
    Posted 6 years ago #

    Thanks, Mike - this gives me hope!

  9. mkirkwag
    Member
    Posted 6 years ago #

    Mike, you are my hero.
    All fixed!

  10. Samuel B
    moderator
    Posted 6 years ago #

    You will need to update all links to new url in your database "wp-options" table

    this is like 4 threads now you have advised people incorrectly to mess with their database.
    1st - your solution was incorrect (which happens to all of us)
    2nd - messing with the database is fairly advanced, especially for new users

  11. mkirkwag
    Member
    Posted 6 years ago #

    Well, in all fairness, that is ultimately what Mike's solution led me to - it's just that I needed that fabulous step by step video to get there - or at least a hint as to how to get into the DB. I was trying to mess with

      files

    . I finally realized that it said "table," but I wasn't getting there on my own.

Topic Closed

This topic has been closed to new replies.

About this Topic