Support » Plugin: No Category Base (WPML) » Loses Permalinkstructure

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Marios Alexandrou

    (@marios-alexandrou)

    It’s not normal that you have to refresh the permalink structure. My guess is there’s some conflict with another plugin that also adjusts the permalink structure e.g. the Yoast SEO plugin. I’m not able to reproduce this problem though so I can’t determine how to fix it.

    dombucheli

    (@dombucheli)

    I’ve disabled some jetpack features. For the moment it seams working. I will tell you if it’s working until monday. Then i think, it’s fine.

    Joeri

    (@joeri1977)

    Same problem here. When I refresh the permalink structure the translated category pages work for a short moment and then I get a 404 error. I am not using any specific plugin that also adjusts the permalink structure. Maybe woocommerce that I am also using.

    dombucheli

    (@dombucheli)

    Im using woocommerce too.
    Do you have a custom link structure for woocommerce?

    Joeri

    (@joeri1977)

    No, just: /shop

    dombucheli

    (@dombucheli)

    Do you use jetpack?

    dombucheli

    (@dombucheli)

    It worked for 48h, then the permalink-structure broke again.

    dombucheli

    (@dombucheli)

    It seems, that adding define('WPLANG', ''); to wp-config.php could helps.

    Joeri

    (@joeri1977)

    Hi Dombucheli,

    Unfortunately this is not working for me. If have turned off the plugin until there is a fix (plugin update) for this problem. No matter what I try nothing seems to help.

    dombucheli

    (@dombucheli)

    Hi Joeri,

    the other thing, what seems important, that you have translatet all the woocommerce permalinkstructure with wmpl string-translation.

    Joeri

    (@joeri1977)

    Hi Dombucheli,

    I don’t think that you translate permalinkstructure (post categories) within string-translation, but under Posts -> Categories my category News is translated correctly in all languages.

    Joeri

    (@joeri1977)

    I think there is an issue with (one of) the latest WPML plugin version because I found another ‘remove category url’ plugin, that is also saying it’s WPML compatible but I have the same problem with that plugin. Hopefully the plugin author can look at this or maybe help me locate the problem.

    dombucheli

    (@dombucheli)

    Try the following:

    Go to WPML -> Translation Management -> Multilingual Content Setup

    Scroll to the bottom and click on Scan now and adjust links

    Hi @joeri1977,

    I found a fix for the Problem:

    I added the following code to the archive.php of my theme:

    <?php flush_rewrite_rules( $hard ); ?>

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Loses Permalinkstructure’ is closed to new replies.