Support » Plugin: Flexible Shipping for WooCommerce » Loopback request error with Flexible Shipping Plugin

  • Resolved rcblizzard

    (@rcblizzard)


    Hi,

    For some reason I keep getting a Loopback request error whenever I activate the Flexible shipping plugin, please let me know how to fix the issue. I currently have the latest wordpress update. Here is the error it shows up in my health check app.

    The loopback request to your site failed, this may prevent WP_Cron from working, along with theme and plugin editors.<br>Error encountered: (0) cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    Please note that if I disable just this one plugin the error does not show but whenever I activate it the error show up again?

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor ospiotr

    (@ospiotr)

    Hello,

    It seems that the error is not related with Flexible Shipping.

    It’s probably something in the hosting configuration. Does your host allow loopback connections? Please contact your server administrator and ask him to allow loopback connections.
    This is required by WordPress itself.

    Plugin Contributor ospiotr

    (@ospiotr)

    Please switch on the WordPress file editor and edit any file, e.g. footer.php and make some changes (e.g. add or remove a blank line). After saving changes, you will see a similar problem related to the loopback. This proves that there is a problem with your server.

    Please contact your server administrator and ask him to allow loopback connections. It will solve your problem.

    When I disable that plugin the loopback error is no longer there, so it’s not the server. Currently WooCommerce plugin works perfectly and no loopback error but whenever I activate that particular Flexible Shipping plugin it happens again?

    Plugin Contributor ospiotr

    (@ospiotr)

    Dear @rcblizzard,

    So, how is the plugin behaving after being deactivated and activated again? Have you checked it?

    It’s still not working.

    I turned on the debug option and this is the warning I keep getting which most likely causing the loopback request error.

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /home/…/public_html/wp-content/advanced-cache.php:22) in /home/…/public_html/wp-content/plugins/flexible-shipping/flexible-shipping.php on line 173

    Plugin Contributor dyszczo

    (@dyszczo)

    Hi @rcblizzard,

    I’s good that you’ve enabled the WP_DEBUG option but unfortunately the message you’ve got is about the plugin which stared writing to the output before any other plugins could set apropriate http headers output started at /home/…/public_html/wp-content/advanced-cache.php:22.
    I’ts probably due to warnings dumped by advanced-cache.php straigh to the output console and it’s a bug in the advanced-cache plugin.

    From what I’ve read in this thread the first error message was about “<br>Error encountered: (0) cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received” and I think this should be our main concern.
    I’ts bad that the plugin goes into infinite loop after the error and the way of reacting to that error is a problem. Although it’s hard to be sure that it’s a flexible shipping problem and the reason for it it’s because flexible shipping does not use curl. There is no curl execution in the flexible-shipping plugin code.
    Flexible shipping is a plugin that facilitates shipping for other plugins so if any of the integrating plugins have problems it may seem that the FS caused it.
    If the curl problem has not been solved yet I would strongly suggest that you should try to find which of the shipping plugins you have is causing it. You can try it by means of:
    – disabling shipping plugins
    – enabling FS
    – if it explodes then try to disable more plugins first so as to have an active FS plugin which is not getting into loop
    – activating the disabled plugin one by one to find the plugin that really caused the problem.

    It’s worth mentioning that curl 28 error is usually caused by the server firewall that prevents some shipping plugin apis to connect with the shipping provider.

    I disabled all the plugins except for the Flexible Shipping and still the Looprequest error shows up but if I disable the Flexible Shipping plugin the loopreqest error does not show up. Pretty sure it’s something to do With the Flexible Shipping plugin not working properly for the newest updated wordpress.

    Plugin Contributor dyszczo

    (@dyszczo)

    Hmm.. are loopreqest still dumping cURL error? If so, then flexible shipping can’t be the main culprit as FS does not have any code related to curl.
    Also I’ve FS installed on my WP 4.9.5 with WC 3.3.5 and it works fine so I will try to go deeper 😉

    Do you have advanced-cache.php in wp-content? If so, please temporarly change its name to advanced-cache.php.old.
    Maybe the theme is trying to add something to shipping methods – please try to switch to StoreFront theme for a second and check if it helps.
    Generally we have to isolate the reason why FS goes berserk.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Loopback request error with Flexible Shipping Plugin’ is closed to new replies.