Support » Plugin: Custom Content Shortcode » Loop pagination issue

  • Hello & thanks a lot for this amazing plugin, which so far has been very handy.

    I’m having the following issue while building a loop with pagination:
    The loop do not update on pages 2,3,4,… : it keeps displaying only the first posts while pagination below remain stuck on page one.

    Maybe something wrong with my shortcodes?

    
    [loop type=post paged=3 maxpage=99 query=default orderby=date status=publish columns=2 pad='0px 10px' class=lc-cc_sc-post_loop-A]
    <div class=lc-cc_sc-post_img_container-A>
    [if image]
    [field image-link size=lc-pic-384 class=lc-cc_sc-post_img-A]
    [else]
    <div class=lc-cc_sc-post_img-A>
    <img src="/wp-content/uploads/2018/07/broken-triangle-2340391-384x384.jpg">
    </div>
    [/if]
    </div>
    <div class=lc-cc_sc-post_summup_container-A>
    <h3>[field title-link class=lc-cc_sc-post_title-A]</h3>
    <h4>[field date class=lc-cc_sc-post_date-A]</h4>
    <p>[field excerpt more='Lire plus' dots=true class=lc-cc_sc-post_excerpt-A]</p>
    </div>
    [/loop]
    [loopage query=default]
    

    Not sure if you can help as the feature is still experimental, but at least this is feedback 🙂
    Cheers.

    • This topic was modified 1 year, 1 month ago by  Motionous.
Viewing 7 replies - 1 through 7 (of 7 total)
  • jenjohn

    (@jenjohn)

    I am having the same issue, not sure when it started. Clicking on the link for page 2, goes to <page url>/?page/=2. Did something change with permalinks?

    jenjohn

    (@jenjohn)

    I have a page, /resources/courses, that has a loop that looks like this:
    [loop type=materials paged=5 query=default]
    [field title]
    [/loop]
    [loopage query=default]

    Then in my settings I have:
    permalink slug: /resources/courses
    pagination slug: page
    default query string: pagename=/resources/courses

    What I’m seeing is that pagination on the first page works fine. If I click page 2, it goes to: /resoruces/courses/page/2/. But from there, all page links look like this: /resources/course/2/page/X (where X is 3, 4, 5, etc.) Clicking on those obviously give me a 404.

    Why is the <2> getting in the string and how do I make it so that it’s just /resources/courses/page/X?

    Thanks!

    RicardoRVM

    (@ricardorvm)

    I am having the same issue. It works fine in the version 3.7.1. From the 3.7.1, it doesn´t works…

    Sorry for my horrible english…

    bgbs

    (@bgbs)

    Try adding replacing query-default to query=paged to both the loop and loopage

    jenjohn

    (@jenjohn)

    No luck. Seems to behave the same as without any query=xxx in the loop and loopage.

    Got it working. For query parameter, use something else instead of “paged”, for example, “pg”. I did that and it worked fine. And have that in the pagination slug setting too.

    Great! Thank you @jenjohn . I’ll give it a try 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Loop pagination issue’ is closed to new replies.