Support » Theme: OceanWP » Looks nice, but…

  • SypoMark

    (@sypomark)


    Adding my own custom styles is always a struggle with WordPress themes: there’s so much already in place that is often hard to find that gets in the way, and needs resetting before the site will take any notice of what I’ve written. But, with OceanWP, it is worse than most.

    And, I’ve noticed, that if I had Blog pages show at most set to a lower number than there are posts, pagination gets created, but, clicking to go through to the next page results in a 404 error screen. This is a page that OceanWP has presumably created, based on pagination rules and the number of posts. But attempting to visit this page results in it saying it doesn’t exist!!!! Not good.

    There are many other things I could say about it, but that will do as a start.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Theme Author oceanwp

    (@oceanwp)

    Hello @sypomark, have you tried to regenerate your permalinks? Go to your dashboard, click Settings > Pagination, click Save Changes, and check if you still have the issue?
    If yes, could you create a pre-purchase ticket in oceanwp.org? I will try to find why you have this problem.

    Thread Starter SypoMark

    (@sypomark)

    Hello @oceanwp.

    Doing as you suggest is not something I’ve tried. But, for our customer, it turns out it’s not relevant: they want all posts belonging to a particular category to appear on the page at once.

    Is there as easy a fix for this issue?

    If I go to Appearance > Customise > Blog > Blog Entries and choose from the dropdown under Blog Style, ‘Large Image,’ there is no displayed setting for number of columns. So, I assumed there would be only one column set. That was a mistake. I discovered that the styling given to the Blog Entries page DID depend on a column count setting … found under a DIFFERENT Blog Style choice: that of Grid. This is even with the styling for any Blog Style SWITCHED OFF under Theme Panel > Scripts & Styles.

    Very frustrating.

    Theme Author oceanwp

    (@oceanwp)

    Hi, I did not quite understand what you want to do, you want to use the Blog Grid style without pagination?
    If yes, you need to select the Grid style in the Blog > Blog Entries section of the customizer, and to display all your posts in your Blog page, go to Settings > Reading and add a big number on posts to show.

    Theme Author oceanwp

    (@oceanwp)

    Hello @sypomark, is your issue is solved?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Looks nice, but…’ is closed to new replies.