Support » Plugin: Knight Lab Timeline » Looks great, doesn’t work

  • I love this tool, but unfortunately the plug-in just doesn’t seem to work. Even using the default Google Docs spreadsheet results in errors. We reverted to using the iframe embed method which works just fine. Not sure if the error is a result of changes to Google Docs, or possibly another update. It’s just a shame – hopefully a future update may resolve the problems. In the meantime, I’d suggest anyone having problems uses the iframe embed method (you can generate the iframe via the Timeline website: http://timeline.knightlab.com/)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor JoeGermuska

    (@joegermuska)

    Regarding your issue about the plugin “not seeming to work,” can you be more specific? I just used it on an install of WP 4.7.2 using version 3.4.0 of the plugin and everything worked as expected. I used this spreadsheet URL:
    https://docs.google.com/spreadsheets/u/1/d/1xuY4upIooEeszZ_lCmeNx24eSFWe0rHe9ZdqH2xqVNk/pubhtml

    I clicked on the “Add timeline” button, pasted the above URL in the “data source” field, and clicked “Insert Timeline”. I then previewed the WP post, and the timeline appeared.

    I then did the same with a brand new copy of the spreadsheet template. Thus, as far as we can tell, there is nothing not working. If you can clarify with information from your browser’s console or other tips, perhaps we could be of more help.

    Note that for many WordPress configurations, iframe markup will not be permitted, or may be permitted based on the permissions for some user roles, but would be at risk of being stripped out by WordPress’s HTML filtering for user roles which don’t have the unfiltered_html capability.

    Thanks Joe! Apologies for lack of info posted; ideally I’d be able to test this with a clean install of WordPress, no plugins, etc., but due to required speed of getting the site off the ground, I wasn’t able to do this.

    I’ll test again and come back with more feedback where applicable.

    In the meantime, the iFrame is working just fine which is great ๐Ÿ™‚

    Cheers,
    Andy

    Hi Joe,

    Finally had a chance to test again with the same set-up. The error message I get is:
    “MISSING START DATE. MAKE SURE THE HEADERS OF YOUR GOOGLE SPREADSHEET HAVE NOT BEEN CHANGED.”

    This is WordPress 4.7.3, running Helium theme and one plugin (Gantry 5 Framework) The same error was received before with same set-up (albeit on 4.7.2 I think!)

    To confirm, I’m using a fresh copy of the spreadsheet template (hasn’t been amended at all, just published to the web).

    I appreciate that this may very well be as a result of incompatibility with Gantry/Helium. If I get the chance, I’ll test on a vanilla install too.

    In the meantime, I’ll revert to using the iFrame method ๐Ÿ™‚

    Thanks again!
    Andy

    Plugin Contributor JoeGermuska

    (@joegermuska)

    Please send details (especially a link to the spreadsheet you’re working with) to our support desk (support@knightlab.zendesk.com or https://knightlab.zendesk.com) so that we can be sure to keep up with your request for help.

    Ok same Problem with Missing Start Date. Using the default Google spreadsheet from knight lab .Starting debugging
    -Spreadsheet header not changed
    – Date format like orginal
    – Spreadsheet shows on the preview embed on the knight lab page
    – New Spreadsheet url generated as recommended on KnightLAb
    Console Error on timeline.min.js
    ypeError: VMM.getJSON(…).error is not a function

    Spreadsheet Url
    https://docs.google.com/spreadsheets/d/1VHkw4nC0-fz7Y7tpfVG_tC8wVKeP2X_HNSvmJMdgOEs/edit#gid=0

    Plugin Author NUKnightLab

    (@nuknightlab)

    If your error refers to VMM.getJSON , you are running an extremely old version of TimelineJS, and one which does not work with the spreadsheet template you used for your timeline.

    If you use the current version of TimelineJS, your spreadsheet works fine, as you can see here.

    If you are actually using the WordPress plugin, we recommend that you update to the latest version served from the WordPress plugin registry

    As noted above, we are better equipped to respond to support requests via our Zendesk system, and request that people use that for anything which is not a topic of general conversation for users of our plugins.

    Please send details (especially a link to the spreadsheet youโ€™re working with) to our support desk (support@knightlab.zendesk.com or https://knightlab.zendesk.com) so that we can be sure to keep up with your request for help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Looks great, doesn’t work’ is closed to new replies.