Support » Plugins and Hacks » Looking for WP-Since Last Visit plugin users

Looking for WP-Since Last Visit plugin users

  • Once I get it functioning, I’m sure this plugin will be invaluable. I just need some help getting rid of an error message. So I’m giving it one last try before hanging it up.

    The error is:

    Warning: Cannot modify header information – headers already sent by (output started at /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/themes/Blix/contact.php:7) in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-last_visit.php on line 55

    I’m not blaming the plugin, but I’m certain it’s related somehow because when I remove the code from my pages, the error no longer appears.

    Please note that I have already scanned the files for extra spaces for the php stuff, which I know is a common reason for this type of message. Still got the same result.

    Can anyone please offer some advice? 🙂

Viewing 15 replies - 1 through 15 (of 54 total)
  • I would think at this point that it’s a conflict between this plugin and another one you have installed. Maybe deactivate all of them, activate this one and get it working, then start adding the rest back one at a time?

    Hmm, good point, vkaryl. Thanks for that bit of advice. I’ll post back my findings. 🙂

    Yes, please do – I’d be willing to bet you won’t be the only one with the problem!

    Well, I don’t think it’s a plugin conflict. Even with all of them turned off, I’m still getting that stubborn error message.

    I’m no php expert, but I still can’t help but wonder if it has to do with the bit of code I was supposed to add to the header.php file. The code I’m talking about is:

    <?php require_once("wp-last_visit.php");
    // set lastvisit cookie

    Since it was supposed to go to the very top of the file, even before the doctype information. You php experts out there may think I’m totally off my rocker, and that’s all right.

    Has anyone else experienced this problem and/or know what to do about it?

    I messed with this pluging for a bout 4 hours today. I had the same problems as you, and I finally gave up.

    I chalked it up to it only being compatible with 1.2 and not 1.5, but I don’t know that for sure.

    Well, at least I feel a little better knowing it’s not just me. 😉

    I was able to get the images to show up (except for one), but with that error message popping up, I think we’re destined to waiting for an update.

    Thanks for weighing in on this, heatsink. 🙂

    No problem – I also wish someone who had this working would speak up (assuming there is someone).

    I thought I had the non-javascript one working for a while, but it quickly became apparent that it wasn’t behaving predictably. The number of new posts and comments never jived correctly with real-life.

    Hoping for a working (1.5?) version though, I love the idea.

    What you could do actually is simply record the info in a DB ??
    What I did with the You Call It / Roept U Maar script is hack-out the cookie to useable names, post that in a DB

    Filter that with the current time-stamp and repost it everytime that person visits. If the person is not in the DB it has not been there before.

    How about that for an idea ??

    Uhmz it also could be who is online script 🙂

    In the who is online script it uses the WP-Cookie to read out information (nickname, URI and email) and posts that in the DB with a time-stamp/

    You could easaly use that timestamp to post the last date the person was on the blog OR post the time that has past since the person was there (or both)

    This would offcourse ONLY work with people who have been there before *grin*

    @mcmike – thanks! It sounds like you’re way more experienced than I am, because I don’t know how to incorporate what you suggested. 😉

    If I posted my code back up with the plugin installed, would you be willing to take a look at it and give me your assessment? Someone with your experience may be able to detect that which has eluded me for a few days now. If not, that’s okay. Just let me know. 😉

    The version of wp-last-visit.php that I run — which I got from here though it appears the same at the repository — doesn’t even have the function you’re trying to call. Perhaps try one of these versions and follow those directions?

    I’m running 1.5.1 and last_visit works fine (I’ve used it since the plugin was first published).
    Do you want the code I use and for me to post where I put the calls ?

    @podz – that would be awesome! Yes, please. 😉 Do I need to be running 1.5.1 then? I didn’t know it was available (I guess I’ve been too busy working on my blog to notice.)

    @coldforged – I could be wrong, but I think I got the code from Alex’s site, but now I’m not sure. If I recall correctly, the link I got was from another post here, so it may be different. The details in the plugin show it to be Alex’s and version 1.3 dated January of 2004. However, it’s not placed in the plugins folder, but in the blog root.

    Thank you both for your help!

    This version is from 07/2004, so it’s newer.

    I’d appreciate that too Podz

Viewing 15 replies - 1 through 15 (of 54 total)
  • The topic ‘Looking for WP-Since Last Visit plugin users’ is closed to new replies.