Support » Fixing WordPress » looking for the help “Core_Upgrader”

  • i am working with WordPress Core update functionality but i am getting below error

    error screenshot

    I have followed a few online tutorials. i am not able to find the soutlion.

    Thanks and help appreciated

    Jatin Devani

    • This topic was modified 2 years, 6 months ago by Jatin Devani.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Please install the health check plugin and report back its findings: https://wordpress.org/plugins/health-check/

    Thread Starter Jatin Devani

    (@jatindevani)

    @sterndata
    Here is my report please check

    ### WordPress ###

    Version: 5.1.1
    Language: en_US
    Permalink structure: /%year%/%monthnum%/%day%/%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.

    ### Installation size ###

    Uploads Directory: 4.00 KB
    Themes Directory: 4.23 MB
    Plugins Directory: 714.78 KB
    Database size: 896.00 KB
    Whole WordPress Directory: 41.57 MB
    Total installation size: 42.45 MB

    ### Active Theme ###

    Name: Twenty Nineteen
    Version: 1.3
    Author: the WordPress team
    Author website: https://wordpress.org/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, responsive-embeds, widgets

    ### Other themes (3) ###

    Twenty Fifteen (twentyfifteen): Version 2.4 by the WordPress team
    Twenty Seventeen (twentyseventeen): Version 2.1 by the WordPress team
    Twenty Sixteen (twentysixteen): Version 1.9 by the WordPress team

    ### Must Use Plugins (1) ###

    Health Check Troubleshooting Mode: Version 1.5.1

    ### Active Plugins (2) ###

    Health Check & Troubleshooting: Version 1.2.6 by The WordPress.org community
    WP Force Field: Version 1.0 by George Katsoudas

    ### Inactive Plugins (4) ###

    Akismet Anti-Spam: Version 4.1.1 by Automattic
    Downgrade: Version 1.0.0 by GraphicEdit
    Hello Dolly: Version 1.6 by Matt Mullenweg
    WP Downgrade | Specific Core Version: Version 1.2.0 by Reisetiger

    ### Media handling ###

    Active editor: WP_Image_Editor_GD
    Imagick Module Version: Imagick not available
    ImageMagick Version: Imagick not available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: Not available

    ### Server ###

    Server architecture: Windows NT 10.0 i586
    Web Server Software: Apache/2.4.37 (Win32) OpenSSL/1.0.2p PHP/7.0.33
    PHP Version: 7.0.33 (Does not support 64bit values)
    PHP SAPI: apache2handler
    PHP max input variables: 1000
    PHP time limit: 30000
    PHP memory limit: 256M
    Max input time: 60
    Upload max filesize: 2000000M
    PHP post max size: 80000000M
    cURL Version: 7.59.0 OpenSSL/1.0.2p
    SUHOSIN installed: No
    Is the Imagick library available: No
    htaccess rules: Your htaccess file only contains core WordPress features

    ### Database ###

    Extension: mysqli
    Server version: 5.5.5-10.1.37-MariaDB
    Client version: mysqlnd 5.0.12-dev – 20150407 – $Id: b5c5906d452ec590732a93b051f3827e02749b83 $
    Database prefix: wp_

    ### WordPress Constants ###

    ABSPATH: D:\xampp\htdocs\wp48/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Enabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Disabled
    WP_DEBUG_LOG: Enabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined

    ### Filesystem Permissions ###

    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable

    `

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    There’s nothing odd there. Try a manual update.

    https://codex.wordpress.org/Updating_WordPress#Manual_Update

    Thread Starter Jatin Devani

    (@jatindevani)

    @sterndata
    I want to create my own functionality to upgrade WordPress core same as WordPress own upgrade functionality. I want upgrade on a button click event but I am getting error. Could you or anyone else provide me technical help regarding this issue. To illustrate error, I have shared screenshot. Note: I do not want to upgrade manually.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘looking for the help “Core_Upgrader”’ is closed to new replies.