[resolved] long post won't save (12 posts)

  1. bodhidude
    Posted 6 years ago #

    I am running WordPress 2.9 and I am having a problem with a long post. This post is just over 11,000 words and when I paste it into WordPress and click save I get a blank page and it is not saved. When I trim down the length of the post it will save but I can't get it to save a post this long. For now I've broken the post into 2 parts but that is not a preferred solution. Does anyone know what could be causing this issue?
    Site URL: http://www.awakeninthedream.com/wordpress/

  2. alism
    Posted 6 years ago #

    Have a look at your error logs if you can to see why it's failing.

    You can also try disabling mod_security if it's running:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    Or speak to your host to see if they can shed any light on it (they might not allow you to disable mod_security for instance).

    Otherwise, usual troubleshooting applies - disable your plugins and switch to the default theme. Try again. If it works, try and narrow it down by re-enabling them one by one.

  3. bodhidude
    Posted 6 years ago #

    Thanks for your suggestions unfortunately still doesn't work. If I try to save a post this long as soon as I hit the update or publish button it goes to a blank page and I have to hit the back button to get back to the WP admin console.
    I tried going to default theme and deactivating pliugins as well as disabling mod_security.

  4. John Dowling
    Posted 6 years ago #


    I had the same problem a while back with a post about 13,000 words long.

    I still have not fixed the problem, but got around it by first creating the post (only about 5000words) and pictures in WordPress so a basic post was in existance. I then edited the database entry via PhpMyadmin of that post and cut and pasted the entire 13,000 words in.

    It now appears. Not a solution though.

  5. bodhidude
    Posted 6 years ago #

    Thanks John, I'll try that. I don't think this a wordpress issue though because I have another wordpress 2.9 site on another webhost and I tried adding this post to that site and it saved and displayed with no problem on that site - same wordpress version, theme and plugins. There must be some setting on some webhosts that creates this problem.

    Anyone know what that might be?

  6. bodhidude
    Posted 6 years ago #

    Ok well I just ended up using PHPMyAdmin to update this post, still don't know what the issue was, oh well. It works this way....

  7. zesty1
    Posted 6 years ago #

    did anyone figure this out???

    this is f'ing ridiculous. ive wasted 3 hours so far trying to fiddle with posts because it doesnt like certain words...

    i can paste in 10000 word over if it doesnt have a certain word (not sure what it is yet, havent narrowed it down), then it works.. if i use the word order it doesnt.. i tried not using the word order and it doesnt work again

  8. Mark / t31os

    Posted 6 years ago #

    If you look at the replies (namingly bodhidude's second to last) above i think it's quite evident the problem is host specific.

    I replied to a thread a while back relating to long posts, i can make posts 100,000 words long an not experience any problems, i've even taken problem pieces of text provided by users having the problem and posted with success.

    Explain the problem to your host and see if there's anything they can do..

    Also consider testing another host(locally if necessary) to reproduce the problem. If the problem doesn't exist on another install then there's little you can do other then consider a new host or put up with said problem.

  9. Sarah Leavitt
    Posted 6 years ago #

    I am having a similar problem -- my site seems to reject certain words. I was unable to save a recent post until I deleted the words "coal" and "Delucci." Seriously. So would this be a host problem as well?

  10. iamrobin
    Posted 6 years ago #

    i'm having a similar issue on my blog: http://blog.airdye.com/goodforbusiness, but the length of the post doesn't seem to be an issue. I've got short posts that reach some magic point and I'm not able to save copy I've typed in.

    When the last line of the post wouldn't save, I started fresh with a new post and built it from the bottom up–the result was that I couldn't save half of the first paragraph. Very, very strange.

    I thought the problem was with the Word document, but my writers have been giving me their posts this way for a year and it's only shown up in the last month or so. I've spent hours on this and am so frustrated.

    I've got another post right now that I'm fighting with. Help! I've already tried disabling all my plugins and even with them all off, I wasn't able to save. I don't have access to PHPMyAdmin.

  11. Floridan
    Posted 6 years ago #

    I had the same problem with disappearing posts until "Rob" at Liquid Web helped me to resolve the issue. He came up with the solution after about 45 minutes of digging and troubleshooting. The fix is to increase the memory limit in your wp_settings.php file which is found in your server root. The number below worked for me! I'm a happy camper now. :)

    if ( !defined('WP_MEMORY_LIMIT') )
    	define('WP_MEMORY_LIMIT', '48M');
  12. blueamulet
    Posted 6 years ago #

    Sorry, deleting post and using contents to begin a new thread :-)

Topic Closed

This topic has been closed to new replies.

About this Topic