Support » Plugin: WebP Converter for Media » Long List of Errors

  • Unfortunately, none of the images can be found. I believe there may be an issue caused by Smush, which was previously installed. I deactivated and uninstalled Smush but it may have caused the image locations to be incorrect. Can anything be done to correct this?

    Link to screenshot

Viewing 10 replies - 1 through 10 (of 10 total)
  • Okay, so I had Jetpack image setting checked. I unchecked it, now all I get is this:

    New Issue Screenshot

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @kdellea,

    Thank you very much for your message. This means that your server probably does not have gd extension enabled.

    Do you use Windows or Linux?

    What is your PHP version?

    Can you check information about PHP’s configuration of your server (please use phpinfo() function)? Please check if you have such data there (please send me please screenshots):
    https://gbiorczyk.pl/webp-converter/gd.png
    https://gbiorczyk.pl/webp-converter/imagick.png

    Try to choose Imagick on settings page of plugin in WordPress admin panel (Settings -> WebP Converter -> Conversion method). You have such a possibility?

    I am using shared hosting through Siteground.com

    I was able to enable Imagick. Now I get this error:

    Imagick does not support WebP format.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @kdellea,
    Thank you for your message.

    Your hosting is very limited. Try to change the server settings to support the WebP format for gd or Imagick.

    Try to contact the support of your hosting. These functions are available natively in PHP, so they should work for you.

    The plugin is protected if the functions are not available. That is why you have the right error message. This is not a plugin error, but a server problem that does not meet the requirements.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Since version 1.0.2 of plugin (always check if you are using the latest version of plugin) you can directly check the configuration of your server in admin panel. The link to it can be found on the plugin’s settings page in the “We are waiting for your message” section or directly at the URL: /wp-admin/options-general.php?page=webpc_admin_page&action=server.

    Please check with particular attention to the selected settings:
    https://gbiorczyk.pl/webp-converter/serverinfo.png

    You do not need to have both gd andimagick extensions enabled – one of them is enough. If you do not have certain options or they are turned off, try to change the configuration of your server. If you can, please contact the support of your hosting. These extensions are natively available in PHP, so there should be no problem to enable or properly configure them.

    In addition, we recommend using PHP from version 7.1, but if you have 5.6 or higher it should also work.

    Is this to solve your issue? Can I help you further? I will be very happy if I helped!

    Hello, I just installed the Plugin on my site and I tried to run the Conversion and I am getting an error:

    An error occurred while connecting to REST API. Please try again.

    How can I fix this?

    Thanks.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hello @cboychuk, please create a new thread for your problem. I will help you there.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @kdellea,

    Hello, did you manage to solve your problem? Can I ask you for some comment on your case?

    The answer from you is very important to me so that my technical support can be improved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.