Support » Alpha/Beta » [Resolved] Long Delays to Update Widget Preview with Customizer

[Resolved] Long Delays to Update Widget Preview with Customizer

  • Running on localhost with Twenty Twelve and the Recent Posts Widget (among others), I’m seeing really long delays before the widget preview updates. It’s often many seconds after both the widget saving spinner and preview highlight/glow border around the relevant widget are gone. The first few times I saw it, actually thought the whole thing was just broken. This also leads to “piled-up” changes getting back-logged.

    Obviously, a faster preview refresh would be the ideal solution, but if that’s not always possible, I’d really consider overlaying a spinner and graying out the widget until the preview updates. Otherwise, it looks like the customizer flat-out doesn’t work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello mrwweb,

    thanks for the report. Is it possible that you record a screencast which you can share with us?

    If not, can you give use some more details about your setup? Which other widgets are you using? Any plugins active?


    The delays between an update and seeing the changes in the preview will be definitively addressed in https://core.trac.wordpress.org/ticket/27355 (Customizer: Add framework for partial preview refreshes)

    However, I noticed that the original logic which waited to remove the spinner until the preview updated got removed. I’ve filed a ticket and supplied a patch to restore this: https://core.trac.wordpress.org/ticket/27635

    Here’s a screencast: http://screencast.com/t/IQaG8Wje Hope that’s useful. I can answer any other questions as best I can.

    Hopefully @weston Ruter’s change will address at least some of this.

    Watching that video, I realized that when a widget was “focused,” it go that blue glow as well. I wonder if that should be persistent the entire time it’s being worked with.

    Thanks a lot, mrwweb. ocean90 just committed my patch, so if you can update to trunk you should be able to see that the spinner persists until the preview refreshes with the updated widgets.

    Sweet. I’ll try to test it out tomorrow when I have a moment but it sounds like the issue is addressed.

    Sorry I’m so late on this.

    Spinner is fixed and looks great. The widget highlighting is still a little confusing to me (I don’t understand what it’s really meant to show), but this is a big improvement.

    Thanks! Yeah, the highlighting is a difficult one to nail down because we don’t want the highlight to be obtrusive, and yet we also need it to work in any theme that we throw at it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Long Delays to Update Widget Preview with Customizer’ is closed to new replies.
Skip to toolbar