Support » Plugin: Gwolle Guestbook » Long admin reply isn’t displayed entirely

  • Resolved zhonglyor

    (@zhonglyor)


    Hi.

    There is 400 words excerpt configured for displaying in frontend. After the excerpt, the “Read more” link is being displayed which rolls down to show the entire entry upon clicking.

    However the long admin reply is excerpted too but without the “Read more” link. After rolling down the entry (if it is long enough), the long admin reply isn’t rolled down.
    So long admin replies need the “Read more” link too.

    P.S. Is it possible to make an option for displaying linebreakes when excerpt is configured? Sometimes it is desireable. Many entries are long, so it looks good when they are rolled to 400 words. However when some poetry is cited, the absense of linebreakes ruins the view.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Marcel Pol

    (@mpol)

    Hi,
    Good catch 🙂
    In the next version there will be a readmore link for the admin reply excerpt.

    About newlines, I don’t see a way to do that. The plugin uses wp_trim_words() function, which strips html tags like line-breaks, but it also trims the characters at the end of the line. So if I run the nl2br() function before or after wp_trim_words() makes no difference.
    https://core.trac.wordpress.org/browser/tags/4.9.4/src/wp-includes/formatting.php#L3359
    I don’t really have a solution for this, unless it is rewriting the wr_trim_words function for this plugin.

    Thread Starter zhonglyor

    (@zhonglyor)

    It works now. Thank you very much.
    By the way I’ve noticed that when clicking the “Read more” link the linebreakes get been shown (the “Show linebreakes” checkbox is checked).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Long admin reply isn’t displayed entirely’ is closed to new replies.