WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Logs folder does not exist and cannot be created

[Resolved] Logs folder does not exist and cannot be created

  • In two installs on the same server, I’m seeing this error when trying to run any job:

    Logs folder does not exist and cannot be created. Please create it and set proper write permissions.

    However, I have checked and double-checked the permissions on the folder, and the entire folder structure, and it definitely does exist and has the correct permissions.

    I have even had the host’s support department confirm that all is well with the permissions.

    Thanks

    http://wordpress.org/extend/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Robert Windisch
    Member

    @nullbyte

    Hi Peter,

    please try to delete the log folder and check the permissions of the parent folder. Our plugin should be able to create this folder when the parent folder permissions allow that.

    regards,
    Robert

    I’ve actually tried creating a completely new folder, still within the uploads folder. I can confirm that permissions on every single folder going right back up to the root are correct.

    I can also confirm that both I and my users are able to upload images and other files into the uploads folder without a problem.

    My host has suggested that the error being reported might be erroneous, as it might be failing for some other reason, but giving an incorrect message about permissions. They suggested a script timeout, but my max timeout is set to 300 seconds and the error is reported almost immediately on clicking on run.

    To make matters more curiouser, I use your plugin on other sites on other servers and have not experienced this problem.

    Finally, all was well until fairly recently. Whether this coincided with a recent update, I can’t say, and I’m always reluctant to use anything but the latest versions.

    Thanks

    Plugin Author Robert Windisch
    Member

    @nullbyte

    Hi Peter,

    we simply try check if the log folder exists. But the error message need to be including the folder we want to create. So maybe your backup options are invalid. Please create a simple new job and check if that message will popup again.

    regards,
    Robert

    Unfortunately not. I made a simple job which just checks the database tables and it still comes up with the error.

    Also, the same error shows in the Settings > Information tab, so it can’t be a script timeout as my host suggests!

    Plugin Author Robert Windisch
    Member

    @nullbyte

    Hi Peter,

    the other folders for your backup were created? What is between this webhost and your other sites where this plugin is working? Can you provide a phpinfo() file?

    regards,
    robert

    The Information tab does not report any problem with the temp folder, although whether it is accessible or not is not known as the job does not run if it can’t access the logs folder.

    The phpinfo file is here: https://www.dropbox.com/s/eoburpvps593ea7/phptest.html

    I can’t tell you the difference between the servers as the others are all part of my work, and I have the week off at the moment, so I can’t run phpinfo on them until next week.

    The only thing I see in the PHP log is this: Warning: Cannot create folder: /nfs/c04/h06/mnt/65449/domains/brightongmc.org/html/wp/assets/backwpup-0f60a-logs in /nfs/c04/h02/mnt/65449/domains/brightongmc.org/html/wp/wp-content/plugins/backwpup/inc/class-job.php on line 911

    Thanks for your help with this

    Peter

    Hello Peter and Robert,

    I’m posting just to tell my experience with the same issue.
    I tried to change the folder permissions, create new jobs, and nothing resolves..

    My solution: just uninstall the plugin completely (via plugin’s page deactivate/uninstall – confirming to exclude all files and data) and reinstall. It solves. The warning listed in the settings > information page disappeared and everything works fine.

    Just one thing: when I access the backups page (and no backups has been done yet), I receive this notice:

    Notice: Undefined offset: 0 in /home/xxxx/public_html/xxxx/xxxx/wp/wp-content/plugins/backwpup/inc/class-page-backups.php on line 176

    It is just a system notice, but needs a conditional isset there 🙂

    Hi Augusto

    Thanks for the thought, but I’m afraid that it’s made no difference! Exactly the same as before.

    Still, I suppose that rules out another possibility!

    Peter

    Inndesign
    Member

    @inndesign

    Same here, install, uninstall, check permissions charmode 755 as normal with version 3.0.12. Warning: Cannot create folder: /home3/plastid6/public_html//wp-content/uploads/backwpup-56609-logs in /home/patsonic/public_html/wordpress/wp-content/plugins/backwpup/inc/class-job.php on line 911

    What a squirrely convoluted plugin. It is trying to create a log in /home3/ which doesn’t even exist, in the account /plastid6/ that doesn’t exist. The correct path is /home/patsonic/. Needless to say, the plugin fails because it improperly renders the path.

    Sadly, I continue to submit one WordPress website as the hapless victim of ongoing failed updates of BackWPup which continues to show no signs of remedy. My other sites continue on version 2.17 flawlessly, which is the last reliable release.

    Solved it! After strenuously denying it had anything to do with them, my host has now admitted that they moved my hosting to a new server. As you refer to the log folder by an absolute path, rather than a local one, it broke!

    So, the absolute path was:

    /nfs/c04/h06/mnt/65449/domains/brightongmc.org/html/wp/assets/backwpup-0f60a-logs

    but my hosting is now on cluster 2, rather than cluster 6, so it should now be:

    /nfs/c04/h02/mnt/65449/domains/brightongmc.org/html/wp/assets/backwpup-0f60a-logs

    What my host did say was that the path should always referred to as a local path, so it should be:

    /home/65449/domains/brightongmc.org/html/wp/assets/backwpup-0f60a-logs

    Perhaps you should change your code accordingly?

    Thanks for all your help

    Peter

    Another Fix!

    My host transfer my websites when they have to or when they want to analyse them for some reason!! I don’t normally have a problem with that until now. I believe it will be a great addition to have a relative path instead of an absolute one.

    The latest answer inspired me to go ahead and check the path of the logs. I noticed that there was a home3 path in the Settings / Logs (tab). I went ahead and remove that. Saved it and the system generated the correct path.

    Afterwards I trying to do a manual backup and it worked.

    Hope that helps!

    Cheers

    I’ve tried all the fixes above to no avail.
    My host has moved the cluster I was on, like Peter vanDoorn’s host did, which apparently was the source of the issue. But it seems bad coding to use an absolute path rather than a local path in your code.
    I’ve wasted too much time with this.
    I’m going to switch to Backup Buddy instead.

    mbrsolution
    Participant

    @mbrsolution

    Hello v before you upgrade to Backup Buddy try the following plugin. You will not be disappointed.

    Kind regards

    mbrsolution… UpdraftPlus does excel over any other WordPress plugin now that BackWPup is a dead duck, without support for months now. However, UpdraftPlus charges for needed functions as additional plugins, functions that are standard with BackWPup. For example, UpdraftPlus will create 5 files if you backup files and database, BackWPup creates one file. If you want to dedicate a storage folder on DropBox, $10 per site extra. When you manage 30 sites, that is not acceptable. BackWPup 2.1.17 was the last working plugin, and is running on all my sites perfectly, performing for free what would cost $125 annually for UpdraftPlus and the needed functions. All things to weigh in the balances, user choice may vary 🙂

    mbrsolution
    Participant

    @mbrsolution

    Hello @inndesign yes you are correct 🙂 I do agree with your comment. I just wanted to point out another plugin that has great support to @jkaki. However when it comes to extras and if you have many websites to manage then perhaps it might not be the best solution.

    Kind regards

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Logs folder does not exist and cannot be created’ is closed to new replies.