Support » Plugin: Yasr - Yet Another Stars Rating » Logs and Schema not working

  • Resolved dkpminus

    (@dkpminus)


    Schema doesn’t seem to be generating. I read your other reviews and worked with my child theme to remove Creative schema in case that was the issue but it did not fix the issue.

    Also the logs are all empty, the ratings show on the frontend but I can’t see them in the backend.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author dudo

    (@dudo)

    Hi, thank you for using Yasr.

    SChema data are generated only by these shortcodes:
    yasr_visitor_votes
    yasr_overall_rating.

    The logs page shows (for now) only the logs for yasr_visitor_votes

    Best,
    Dario

    • This reply was modified 11 months, 4 weeks ago by dudo.

    I don’t understand, how are you supposed to use multi-sets and still get schema markup then?

    Plugin Author dudo

    (@dudo)

    Let me explain better:
    The standard by schema.org has 2 types of property for the ratings:
    ReviewRating (covered by yasr_overall_rating)
    aggregateRating(covered by yasr_visitor_votes)

    There is not a specific standard for a multiset (that has many ratings); I can workaround this by adding the schema using aggregateRating for the average row in the multiset.

    I’ve added this in my “todo” list

    Ah, I see now. Yes my assumption was that it would use the average of the overall rating for aggregateRating schema.

    Regarding the logs, mostly I only am trying to figure out how to integrate this with Toolset (views, layouts, etc), as Toolset does not have rating functionality built in. Can you tell me which table/field the overall rating is stored in so I can try to connect it to Toolset to allow sorting?

    Thank you!

    Plugin Author dudo

    (@dudo)

    It is in the post_meta

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Logs and Schema not working’ is closed to new replies.