Support » Plugin: ProfileGrid - User Profiles, Groups and Communities » Logout to URL feature request

  • Resolved cynya

    (@cynya)


    The option for Redirect on Logout is to pages. I want the members to logout to the main website page which would require an URL redirect. So I thought that you might consider this feature for an upcoming release.

    Currently, as a work-around I have created a “Thank You for Visiting Page” with a meta refresh tag to redirect to an URL.
    <meta http-equiv=”Refresh” content=”0; url=https://www.your-URL.com” />

    This works, so I am posting for others, but it’s not a preferred choice. NOTE: content=0 means redirect right away, but can be changed to reflect the number of seconds before redirect. So content=5, would show Thank You page for 5 seconds before redirecting. I also have a link to website on the Thank You page in case redirect fails.

    • This topic was modified 3 months, 3 weeks ago by cynya. Reason: Add more info
Viewing 5 replies - 1 through 5 (of 5 total)
  • Another question along same lines. If you change the Settings to remove the WordPress toolbar, how does the member logout? I am trying out the ProfileGrid Login menu, but seems to me there should be a Logout button in the same place.

    Also, there seems to be a bug on Redirect to UserBlogs. If the member does not have any blogs this message displays: “Sorry, has not made any blog posts yet.” It seems the code intended to include the member’s name, so it would say “Sorry, MEMBER has not made any blog posts yet.” And that’s not working.

    Plugin Support profilegrid0

    (@profilegrid0)

    Hello @cynya,

    Thank you for writing to us.

    We have noted your concerns regarding the logout feature and the logout link in user profile. Management team will review and analyse this for inclusion in a future version update.

    Currently, a user will see the logout link on the PM_Login page if the user is logged in already.

    Regarding the message on no user blogs, it does display the name of member. Could you please share screenshots of your user profile page in dashboard and frontend so we can analyse the issue in a better way.

    Let us know if you have any other questions.

    My site is not yet live. I am providing a Google Docs link where I have posted a screenshot of “Sorry, has not made any blog posts yet”

    https://docs.google.com/document/d/1D3Y_faXKz1c34HyyANrarhTDMX5Xjg37lSN3gkbVwws/edit?usp=sharing

    Plugin Support profilegrid0

    (@profilegrid0)

    Hello @cynya,

    Thank you for sharing the document. We have noted this issue and will release a fix for this in our upcoming version update.

    Let us know if you have any other questions.

    Well, for whatever reason, it is working for me now, so I thought that you had resolved! Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.