Support » Plugin: Slide Anything - Responsive Content / HTML Slider and Carousel » logos slider not working on Microsoft Edge browser?

  • Resolved kikib

    (@kikib)


    It’s working fine on Google Chrome browser, which is the default browser that I use often. However, when I check browser compatibility on Microsoft Edge, it didn’t display the logos at all….

    I think jquery is enable…

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author simonpedge

    (@simonpedge)

    Have a look at the Slide Anything PRO demo page within your EDGE browser:
    https://edgewebpages.com/
    There are 3 sample Slide Anything sliders on this page. I just tested this page within my EDGE browser and it displays fine.

    Also, I had a look at http://test.idssite.com/ within my CHROME browser, and the ‘Our Clients’ and ‘Our Partners’ Logos are NOT displaying – so this is not a browser compatibility issue.

    Some things you can try:
    1) Try ticking the ‘DOMContentLoaded event’ checkbox (under ‘Other Settings’) for your slider
    2) If you have a caching plugin – try disabling it
    3) If you have any sort of optimization plugin that combines/minifys JavaScript, try disabling it, or just the JS Minify part of that plugin.

    Thread Starter kikib

    (@kikib)

    I think I found the problem. It was the Autoptimize plugin that I used. When I deactivate the plugin, the slider shows up. Is there any scripts that I can add to exclude scripts from Autoptimize?

    The plugins that I have are Autoptimize, Async JavaScript, and WP Fastest Cache.

    Additionally, I tried to follow your instructions.
    1. I clicked on “DOMContentLoaded event” checkbox but it’s still not showing.
    2. I did disable WP Fastest Cache but I found out that it’s not the problem.
    3. I did try to disable anything concerning JS in Autoptimize but it didn’t work….

    Plugin Author simonpedge

    (@simonpedge)

    I don’t know – you will have to ask the developers of that plugin
    (I have never used ‘Autoptimize’ before)

    Hi, Frank (AO dev) here 🙂

    Simon; the question is simply what JS files does your plugin enqueue so kikib can exclude those from being optimized. I as AO dev cannot know that 🙂

    hope this clarifies,
    frank

    Plugin Author simonpedge

    (@simonpedge)

    /wp-content/plugins/slide-anything/owl-carousel/owl.carousel.min.js

    hope that helps 🙂

    Thread Starter kikib

    (@kikib)

    @simonpedge

    I did add wp-content/plugins/slide-anything/owl-carousel/owl.carousel.min.js to the box under “Exclude scripts from Autoptimize:” but it’s not working.

    What about the css? I see that there’s another box for CSS under “Exclude CSS from Autoptimize:”.

    I’m even checking out the question I found on Autoptimize support: https://wordpress.org/support/topic/optimize-js-breaks-owlcarousel-js/ but I couldn’t find any solution since I’m using Divi theme. Also, I don’t think that this problem described in this question applies to me.

    Should I move over to Autoptimize and open a support thread for Slide Anything plugin/owl-carousel compatibility?

    Plugin Author simonpedge

    (@simonpedge)

    Try adding the following CSS:
    /wp-content/plugins/slide-anything/owl-carousel/owl.carousel.css
    /wp-content/plugins/slide-anything/owl-carousel/sa-owl-theme.css
    /wp-content/plugins/slide-anything/owl-carousel/animate.min.css

    Also why testing all this out – disable any caching plugin

    • This reply was modified 3 years, 5 months ago by simonpedge.
    Plugin Author simonpedge

    (@simonpedge)

    Hi, did this help you resolve your issue?

    Thread Starter kikib

    (@kikib)

    Hi, after corresponding with Autoptimize plugin author, we narrowed down the problem. It was Shortpixel option which convert a background url, for example,

    background-image:url("http://test.idssite.com/wp-content/uploads/2019/03/breastcarecenterslogo.png");

    into

    background-image:url(https://cdn.shortpixel.ai/client/q_lossy,ret_img/"http://test.idssite.com/wp-content/uploads/2019/02/dellcolor.png");

    The problem lies with the quotation marks. Somehow, when I added an image to the slide background, it was set like this

    background-image:url("http://test.idssite.com/wp-content/uploads/2019/03/breastcarecenterslogo.png");

    when it should be
    background-image:url("http://test.idssite.com/wp-content/uploads/2019/03/breastcarecenterslogo.png");

    or

    background-image:url(http://test.idssite.com/wp-content/uploads/2019/03/breastcarecenterslogo.png);

    • This reply was modified 3 years, 5 months ago by kikib.
    Plugin Author simonpedge

    (@simonpedge)

    Yes, there is an issue with the Auto-Optimize plugin when the option to enable the Shortpixel CDN is enabled. Un-check the ‘Optimise Images’ checkbox under the Images tab to resolve this issue.

    Autoptimize 2.6 will work around the "-issue, if you want you can download the beta from https://github.com/futtta/autoptimize/archive/beta.zip

    hope this helps,
    frank

    Plugin Author simonpedge

    (@simonpedge)

    Thanks for the feedback Frank 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘logos slider not working on Microsoft Edge browser?’ is closed to new replies.