WordPress.org

Support

Support » Themes and Templates » Customizr » Logo will not upload correctly in Customizr

Logo will not upload correctly in Customizr

  • I have tried numerous times unsuccessfully to upload my logo in .jpg and .png format, neither version work and when I view the home page there is a broken icon where the logo should be. Any ideas how to fix this issue?

Viewing 15 replies - 1 through 15 (of 29 total)
  • Probably a plugin conflict.

    Deactivate all plugins
    Test if OK
    If OK, reactivate plugins one-by-one to find the culprit

    If not that, try changing to a different Theme (eg twentyfourteen) and test it. This will show if it is dependent on Czr.

    Link to site would help us.

    link to site is http://www.platinumfinancial.ie

    Thanks,

    I have tried deactivating all plugins which has no effect.

    File is not accessible from the server:
    src="http://www.platinumfinancial.ie/wp-content/uploads/Platinum-Logo-Blue31.jpg"

    – Is the file there?
    – Correct path?
    – Correct Permissions?

    Another possible fix: try disabling Retina support in Customiz’it!>Images before uploading

    I have tried disabling retina support. Still no joy! I have noticed that when I upload an image I need to edit it first in the media library in order for it to display. How can I upload the image from the WP media library instead of from my computer.

    I have tried disabling retina support which has not worked either. I have noticed that when I upload media I need to edit it in the library before it will display correctly. How can I upload the media library image instead of having to upload it from the computer as I think this is what is causing the issue?

    I still have no luck inserting my logo into the customizr theme.
    Can anyone help?

    Dave’s suggestions are good ones:

    – Is the file there?
    – Correct path?
    – Correct Permissions?

    I have the same problem. The reason is that when I try uploading the logo from customization admin panel the path to the image is relative to PC and not to the web server.
    Examining the published theme code with firebug, is obvious where the problem is.
    The right path of the logo image should be:
    http:///www.site name/wp-content/uploads/subdir with year /subdir with month/logo image name
    but uploading from the upload button on the customization panel, the path become:
    /subdir with year /subdir with month/logo image name
    that is wrong.
    So I am trying to solve by making a backup of the MySQL database from the webserver, and changing the path of the uploaded image logo from the wrong path to the right path and, than, reuploading the corrected backup to the server.
    Please let me know if there is another way.

    It looks weird, tried also to remove the logo and upload it again?
    You can also try a different thing, if you don’t wanna mess with the db.
    In your child-theme functions.php:

    add_filter('tc_logo_src', 'my_logo_src');
    function my_logo_src() {
        $logo_abs_path = "SOME_ABS_PATH";
        return $logo_abs_path;
    }

    edit:
    anyway this regards to a new feature added in 3.1.11, in order to use relative paths.

    I have just tried your suggestion but this only insert the site title instead of the broken image sign.
    The strange thing happened to me today, after having upgraded the new theme version and after having uploaded a favicon.
    But I had never uploaded a favicon after having loaded the site to the web server, so I cannot say whether there is some problem with the theme upgrade.
    If you do not have any other suggestion, I will try with exporting the db, but I would like to know if it is possible to export only a SQL table that contains all the wordpress variables like path (I do not know if there is one) or if it is necessary to export all .sql database.
    Thanks for your help.

    What have you tried?
    That code doesn’t work for you?
    Weird, it works for me.. what’s the extension of your logo image?
    About sql, yeah you can export wp_options (the option you’re looking for is tc_theme_options -> “tc_logo_upload”)

    In my custom function.php I have added your code (Note that other added functions work well). Than I have tried to reload the logo image with png. extension, the same that I had already used, but it seems that doing this is like saying to the theme that there is no image loaded and it use the default site title view.
    If it is of some help, the site is:
    http://www.laboratorioab.it
    In local the image is correctly displayed and uploaded with correct path (local path).

    Yep I remembered you site 😀
    Anyway it’s weird, ’cause if I set simply a wrong path in that code it shows me a “broken” image, but if I set a path to an image (existing or not) with a non-accepted extension, then I get your result (title instead of the image). That’s why I asked that.
    Sorry cannot get the reason of this behavior.

    Ok thanks so much! I am trying changing the db.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Logo will not upload correctly in Customizr’ is closed to new replies.
Skip to toolbar