Support » Plugin: Smush - Lazy Load Images, Optimize & Compress Images » Logo is not showing when lazy load

  • Resolved fredbangkas

    (@fredbangkas)


    When lazy load is active the logo is not loading even if I have already added an ID and then add it on the exclude.

    Is there a way to show the link privately?

Viewing 6 replies - 16 through 21 (of 21 total)
  • I would have to echo the same issue here too – A logo image in my footer of my theme stopped showing. Eventually had to disable .png from being lazy loaded. Setting custom class and id’s to be ignored did not work. And even adding in additional images to be lazy loaded in the footer resulted in those not appearing – the image markup had it’s class values all removed and only “lazyloaded” was present.

    I did also not that even adding in extra test images below this png logo in the footer resulted in the images all having an SRC of “data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==” Is there a cache that we can delete for the Lazy Load? Also – the base64 is showing “gif”, but the image was a “png” – could that be the issue in it not showing up?

    I have disabled PNG from the allowed images, and it is now showing back up.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @fredbangkas, @chunkysteveo,

    Without seeing the actual issues it’s hard to guess what might be wrong. Could be a conflict, could be an error. Please provide links to pages, where this can be seen.

    Best regards,
    Anton

    I’m also having the same issue with parts of our website. It appears that it doesn’t affect all pages. Does affect home page.

    http://bit.ly/2MCFFPu

    Thank you!

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @russelln254

    I hope you’re well today!

    It appears that it doesn’t affect all pages. Does affect home page.

    I’ve just visited the site and it seems logo is displaying fine on the homepage – if we’re referring to the one in the top-left corner. I’m guessing though that Lazy Load is currently disabled or the homepage is excluded from it, correct?

    If you can’t keep it enabled, could you please do as follows:
    – enable it to reproduce the issue
    – use browser “Inspect element” tool to inspect the logo image (might be a bit “tricky” to inspect correct location without seeing an image but if you do it first when logo is visible you should be able to do it again after it’s missing)
    – and take a screenshot of a page source code (that’ll be displayed in browser webdeveloper console automatically) that it shows with us here?

    This should show what changes happen there if Lazy Load is enabled.

    Best regards,
    Adam

    Hey @wpmudev-support8

    I’m not sure what was causing the original problem. What I finally got to work was to make a copy of the homepage and sermon page (those were the two with problems). After doing that and replacing the originals it started showing again.

    Thanks!
    Russell

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @russelln254

    Thank you very much for updating us on this and it’s good to know that it’s finally working for you!

    I’d risk saying – based on what helped – that it was after all related to some caching (or if you’re using some “page builder” tool – a matter of regenerating resources) but still, it’s great to know it’s working.

    Thanks and we’ll keep close eye on all the similar cases!

    Best regards,
    Adam

Viewing 6 replies - 16 through 21 (of 21 total)
  • The topic ‘Logo is not showing when lazy load’ is closed to new replies.