Support » Plugin: Smush - Lazy Load Images, Optimize & Compress Images » Logo is not showing when lazy load

  • Resolved fredbangkas

    (@fredbangkas)


    When lazy load is active the logo is not loading even if I have already added an ID and then add it on the exclude.

    Is there a way to show the link privately?

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Support Jonathan – WPMU DEV Support

    (@wpmudev-support9)

    Hello @fredbangkas,

    Hope you’re doing well!

    When creating a thread please place your site’s URL to the field called Link to the page you need help with:

    If this filed will not be shown, please use https://bitly.com/ and share shortened link of your site in here so we could have a closer look at the logo image.

    Please advise,

    Kind regards,
    Nastia

    Thread Starter fredbangkas

    (@fredbangkas)

    Hi

    Here is the link https://danielbussius.com/ so you can check out how the lazyload affects the logo.

    Thanks

    Plugin Author Anton Vanyukov

    (@vanyukov)

    @fredbangkas,

    You don’t need to lazy load the logo, because it will be auto loaded once the page loads (it’s in users view port). So could you please add #logo-img to Classes & IDs exclusion list in Smush lazy load module?

    Best regards,
    Anton

    Thread Starter fredbangkas

    (@fredbangkas)

    Yes that is the problem I already added it in the field and it is still adding the lazyload tag. I excluded it and add it on the list of id’s and classes to be excluded. But if I add other class .tve_image to the list it is working and excluding it. Any reason why it is doing that?

    Thread Starter fredbangkas

    (@fredbangkas)

    I was thinking of another way is there a way that I can add a class that automatically excludes that image? like no-lazy-load class or tag that I can use?

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hello @fredbangkas

    I checked the site again and I see that the logo seems to be affected by lazy-load. I have, however, also noticed that there’s cache active on site and the theme that you’re using is also one that’s providing some optimization options.

    Could you then give it another try, please? Try this way:

    1) make sure that “#logo-img” ID is added (in its own single line) to the “Classes & IDs” option in “Exclusions” section of Smush “Lazy Load” configuration
    2) check if you can switch off any “lazy loading” option for images in your current theme’s settings and in your caching plugin – and if so, disable them
    3) clear cache on site (and, preferably, in browser too)

    and check the site again. Let us know if the logo is still affected or if it’s fine after that.

    As for your recent question – no, there’s no option to add such “exclusion class”. Instead, you can specify which classes/IDs should be ignored and/or what post types (e.g. “posts”, “pages” etc) shouldn’t use Lazy Load feature.

    Best regards,
    Adam

    I’m having what looks like the exact same issue on a client’s website: https://bit.ly/2lINqtI

    Looks like both are using a Thrive Themes wp theme and both using W3 Total Cache. I’ve followed the above advice and it’s still not showing up.

    The logo is the only image affected.

    Plugin Author Anton Vanyukov

    (@vanyukov)

    I’m trying to debug this issue to get a fix. For now, there’s a .no-lazyload class that can be added to images to avoid them being lazy loaded.

    Best regards,
    Anton

    Thread Starter fredbangkas

    (@fredbangkas)

    Hi

    Yes it is on its own line, it is the only one on the exclude box.
    I have turned off other caching plugin as well and empty cache.

    Also Stevybuk has the same issue I just checked his linked and it a similar issue.

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @fredbangkas

    Did you try to use the workaround shared by Anton above?

    For now, there’s a .no-lazyload class that can be added to images to avoid them being lazy loaded.

    Warm regards,
    Dimitris

    Thread Starter fredbangkas

    (@fredbangkas)

    Hi Dimitris

    Yes I just tested it now and it is not working I added the no-lazyload class, turn off and on the lazyload settings and empty cache and it not working.

    Tested also when all caching plugin is off no luck.

    Any other work around?

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @fredbangkas ,

    I checked your site and I don’t see class no-lazyload in the classes in the img logo. How did you add it? Or you have already removed that class?

    kind regards,
    Kasia

    Thread Starter fredbangkas

    (@fredbangkas)

    Hi Kasia that is the weird thing it removes the logo classes ang just use the lazy load class. it has l-l and no-lazyloading class on it and when Smush lazyload is active it removes the other classes

    Plugin Support Dimitris – WPMU DEV Support

    (@wpmudev-support6)

    Hello @fredbangkas

    Could you please send me an email to contact@wpmudev.org using this template:

    Subject: “Attn: Dimitris

    Message: link back to this thread for reference

    Keep in mind the subject line as ensures that it gets assigned to me.

    Thank you,
    Dimitris

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    If this filed will not be shown, please use https://bitly.com/ and share shortened link of your site in here so we could have a closer look at the logo image.

    No, never suggest that. Short links have been abused and are expanded when found as I just did. Don’t use them ever here.

    @fredbangkas Don’t bump.

    https://wordpress.org/support/guidelines/#do-not-bump-posts

    I’ve archived your bumps.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Logo is not showing when lazy load’ is closed to new replies.